# Regional Discussions

**URL:** https://discuss.kubernetes.io/c/regional-discussions/15.md

[Latest](https://discuss.kubernetes.io/latest.md) · [Categories](https://discuss.kubernetes.io/categories.md) · [Tags](https://discuss.kubernetes.io/tags.md)

---

## [About the Regional Discussions category](https://discuss.kubernetes.io/t/about-the-regional-discussions-category/2880)

<div class="topic-metadata">

**Author:** [@mrbobbytables](https://discuss.kubernetes.io/u/mrbobbytables)\
**Replies:** 3\
**Last updated:** [November 1, 2018, 11:56am UTC](https://discuss.kubernetes.io/t/about-the-regional-discussions-category/2880 "2018-11-01T11:56:43Z")

</div>

The Regional Discussions Category is intended for those users that belong to a specific region or share a common language to openly interact and connect with each other in their native language. If you are interested in …

---

## [Readiness probe](https://discuss.kubernetes.io/t/readiness-probe/34826)

<div class="topic-metadata">

**Author:** [@Qazaidi123](https://discuss.kubernetes.io/u/Qazaidi123)\
**Replies:** 1\
**Last updated:** [July 2, 2026, 6:50am UTC](https://discuss.kubernetes.io/t/readiness-probe/34826 "2026-07-02T06:50:16Z")

</div>

When a readiness Probe failed, kubernetes remove the Pod from the service point so that traffic could not move toward that pod. Pod remain in the node. Kubernetes continues to run the readiness probe checks against the c…

---

## [Grundsätzliche Netzwerkfrage](https://discuss.kubernetes.io/t/grundsatzliche-netzwerkfrage/34515)

<div class="topic-metadata">

**Author:** [@rajan](https://discuss.kubernetes.io/u/rajan)\
**Replies:** 0\
**Last updated:** [April 24, 2026, 8:11am UTC](https://discuss.kubernetes.io/t/grundsatzliche-netzwerkfrage/34515 "2026-04-24T08:11:06Z")

</div>

Hallo, ich beschäftige mich eigentlich nicht mit Kubernetes direkt. Jetzt soll ich zwei Maschinen in einer Kubernetes Umgebung betreuen. Beide Maschinen sind als Bots eingerichtet und haben idente Netzwerkadressen. Die…

---

## [Calico-kube-controllers 问题排查](https://discuss.kubernetes.io/t/calico-kube-controllers/34458)

<div class="topic-metadata">

**Author:** [@chalinlin8](https://discuss.kubernetes.io/u/chalinlin8)\
**Replies:** 1\
**Last updated:** [April 13, 2026, 1:28pm UTC](https://discuss.kubernetes.io/t/calico-kube-controllers/34458 "2026-04-13T13:28:00Z")

</div>

calico-kube-controllers STATUS 状态码：CrashLoopBackOff kubectl-api正常的，iptables 转发也是正常的，怎么排查啊 日志详情，2026-04-13 07:33:21.150 \[INFO\]\[1\] main.go 107: Loaded configuration from environment config=&config.Config{LogLevel:“info”,…

---

## [Best shortcut for working on K8](https://discuss.kubernetes.io/t/best-shortcut-for-working-on-k8/24834)

<div class="topic-metadata">

**Author:** [@zorrosam](https://discuss.kubernetes.io/u/zorrosam)\
**Replies:** 4\
**Last updated:** [January 3, 2026, 2:08pm UTC](https://discuss.kubernetes.io/t/best-shortcut-for-working-on-k8/24834 "2026-01-03T14:08:05Z")

</div>

Come vedete configurare questi shortcut quando si lavora su kube? alias k=kubectl # will already be pre-configured export do=‘–dry-run=client -o yaml’ # k create deploy ngin…

---

## [\[求助\] 關於多個集群發生NodeNotReady](https://discuss.kubernetes.io/t/nodenotready/33604)

<div class="topic-metadata">

**Author:** [@justkugi](https://discuss.kubernetes.io/u/justkugi)\
**Replies:** 0\
**Last updated:** [November 13, 2025, 8:52am UTC](https://discuss.kubernetes.io/t/nodenotready/33604 "2025-11-13T08:52:44Z")

</div>

遇到的問題描述如下： 在 2025-11-06 約 23:00 在 “多個” 集群上發生 NodeNotReady events ， 包含了Control plane 及 Worker Node， 只有少數 2~3 node 沒有NodeNotReady events 。 其中有etcd cluster 的其中一follow 有出現fsync 延遲過高的現象(最高到8s)，持續時間約23:00~23:15 左右。 對應的API…

---

## [Building a Kubernetes 1.27 Cluster with \`kubeadm\`](https://discuss.kubernetes.io/t/building-a-kubernetes-1-27-cluster-with-kubeadm/25585)

<div class="topic-metadata">

**Author:** [@kemo](https://discuss.kubernetes.io/u/kemo)\
**Replies:** 1\
**Last updated:** [October 4, 2025, 4:55pm UTC](https://discuss.kubernetes.io/t/building-a-kubernetes-1-27-cluster-with-kubeadm/25585 "2025-10-04T16:55:51Z")

</div>

What are the inconvenience for this cluster creating and is it suitable for companies ?? I think its the fastest cluster creation way Building a Kubernetes 1.27 Cluster with kubeadm Install Packages Log in to the cont…

---

## [Regarding port forward](https://discuss.kubernetes.io/t/regarding-port-forward/32929)

<div class="topic-metadata">

**Author:** [@venkatesh](https://discuss.kubernetes.io/u/venkatesh)\
**Replies:** 0\
**Last updated:** [August 12, 2025, 1:15pm UTC](https://discuss.kubernetes.io/t/regarding-port-forward/32929 "2025-08-12T13:15:12Z")

</div>

we have installed ansible awx in Kubernetes its installed successfully after doing portfowarding its working fine without port-forwarding its not working fine. please give suggestion how it will work without port-forwar…

---

## [Kubectl with kustomize should patch a value but will not](https://discuss.kubernetes.io/t/kubectl-with-kustomize-should-patch-a-value-but-will-not/32730)

<div class="topic-metadata">

**Author:** [@Lars](https://discuss.kubernetes.io/u/Lars)\
**Replies:** 1\
**Last updated:** [July 17, 2025, 6:01am UTC](https://discuss.kubernetes.io/t/kubectl-with-kustomize-should-patch-a-value-but-will-not/32730 "2025-07-17T06:01:18Z")

</div>

I have a base and overlay system. Something similar to the following code part. apiVersion: apps/v1 kind: Deployment metadata: name: frontend-deployment spec: selector: matchLabels: app: frontend…

---

## [Schulung Kubernetes in deutsch?](https://discuss.kubernetes.io/t/schulung-kubernetes-in-deutsch/32701)

<div class="topic-metadata">

**Author:** [@Freed2020](https://discuss.kubernetes.io/u/Freed2020)\
**Replies:** 0\
**Last updated:** [July 9, 2025, 6:50pm UTC](https://discuss.kubernetes.io/t/schulung-kubernetes-in-deutsch/32701 "2025-07-09T18:50:36Z")

</div>

Hallo, ich suche eine gute Schulung für Kubernetes. Mein Unternehmen würde mir da was bezahlen. Ich würde die Schulung gerne in deutsch haben. Könnt ihr mir was empfehlen? Wenn es geht im Paket mit Docker, GitLab Ci/CD…

---

## [\[求助\]Kubernetes核心组件配置资源限制](https://discuss.kubernetes.io/t/kubernetes/32112)

<div class="topic-metadata">

**Author:** [@wangxian](https://discuss.kubernetes.io/u/wangxian)\
**Replies:** 1\
**Last updated:** [April 23, 2025, 6:45am UTC](https://discuss.kubernetes.io/t/kubernetes/32112 "2025-04-23T06:45:23Z")

</div>

对于一个50节点以下的Kubernetes集群，我应该为apiserver、controller-manager、scheduler和kube-proxy分配多少cpu和内存比较合理

---

## [Kubernetes Cluster auf verschiedene Provider aufteilen?](https://discuss.kubernetes.io/t/kubernetes-cluster-auf-verschiedene-provider-aufteilen/23953)

<div class="topic-metadata">

**Author:** [@IOSalex](https://discuss.kubernetes.io/u/IOSalex)\
**Replies:** 5\
**Last updated:** [February 8, 2025, 8:26am UTC](https://discuss.kubernetes.io/t/kubernetes-cluster-auf-verschiedene-provider-aufteilen/23953 "2025-02-08T08:26:28Z")

</div>

Nachdem ich meine Vorstelllung abgeliefert habe, starte ich nun mal mit meinen (vermutlich dummen…) Newbie-Fragen: Kann man Kubernetes Cluster auf verschiedene Provider (Managed Services) aufteilen? Beispiel: Provide…

---

## [Can't connect server Node to database MySQL in Kubernete](https://discuss.kubernetes.io/t/cant-connect-server-node-to-database-mysql-in-kubernete/31153)

<div class="topic-metadata">

**Author:** [@Michal\_Zakrzewski](https://discuss.kubernetes.io/u/Michal_Zakrzewski)\
**Replies:** 0\
**Last updated:** [January 9, 2025, 3:03pm UTC](https://discuss.kubernetes.io/t/cant-connect-server-node-to-database-mysql-in-kubernete/31153 "2025-01-09T15:03:48Z")

</div>

Error: getaddrinfo ENOTFOUND mysql-service at Object.createConnectionPromise \[as createConnection\] (D:\\Nodejs\\Backend\\node\_modules\\mysql2\\promise.js:18:31) at connectToDatabases (D:\\Nodejs\\Backend\\db.js:21:39) at star…

---

## [【特性请求】Daemonset/Deployment细粒度扩缩容](https://discuss.kubernetes.io/t/daemonset-deployment/30760)

<div class="topic-metadata">

**Author:** [@unilinu](https://discuss.kubernetes.io/u/unilinu)\
**Replies:** 1\
**Last updated:** [December 30, 2024, 7:46am UTC](https://discuss.kubernetes.io/t/daemonset-deployment/30760 "2024-12-30T07:46:35Z")

</div>

为什么需要 当前，Daemonset/Deployment（ReplicaSet）对滚动更新做了一定程度的策略控制，但是对于大批量扩容却基本没做什么，除了限制对API-Server的请求压力。这使得当它们大批量扩容也就是大量Pod同时创建时，会引发对同类资源的并发争抢，进而不断的失败重试，导致扩容过程什么缓慢。所以，是否应该考虑对Daemonset/Deployment扩缩容Pod也进行用户可定义的并发控制？ 在Daemonset/D…

---

## [Kubectl create deployment pull image error](https://discuss.kubernetes.io/t/kubectl-create-deployment-pull-image-error/30886)

<div class="topic-metadata">

**Author:** [@LuoYubiao](https://discuss.kubernetes.io/u/LuoYubiao)\
**Replies:** 0\
**Last updated:** [December 20, 2024, 3:09am UTC](https://discuss.kubernetes.io/t/kubectl-create-deployment-pull-image-error/30886 "2024-12-20T03:09:11Z")

</div>

使用 kubectl create deployment nginx --image=nginx:latest --namespace develop-public --replicas 1 命令部署 nginx 时，pod 日志中报错镜像拉取失败，但是我在 master 和 worker 两个 node 都可以使用 docker pull 拉取到镜像。请问大家需要如何解决此问题？

---

## [Error when adding ConfigMap data into deployment yaml](https://discuss.kubernetes.io/t/error-when-adding-configmap-data-into-deployment-yaml/30885)

<div class="topic-metadata">

**Author:** [@tron40a](https://discuss.kubernetes.io/u/tron40a)\
**Replies:** 8\
**Last updated:** [December 19, 2024, 9:13pm UTC](https://discuss.kubernetes.io/t/error-when-adding-configmap-data-into-deployment-yaml/30885 "2024-12-19T21:13:12Z")

</div>

Hey everyone, really new to Kubernetes and need a little help. Have anyone of you come across this? Error when trying to apply ConfigMap to deployment yaml. error when creating “httpd-deployment-datacenter.yaml”: Deplo…

---

## [When I use kubeamd init creating cluster runtime raise error info API server is not heathly? My OS is Debian 12.8.0](https://discuss.kubernetes.io/t/when-i-use-kubeamd-init-creating-cluster-runtime-raise-error-info-api-server-is-not-heathly-my-os-is-debian-12-8-0/30843)

<div class="topic-metadata">

**Author:** [@LuoYubiao](https://discuss.kubernetes.io/u/LuoYubiao)\
**Replies:** 19\
**Last updated:** [December 18, 2024, 7:37am UTC](https://discuss.kubernetes.io/t/when-i-use-kubeamd-init-creating-cluster-runtime-raise-error-info-api-server-is-not-heathly-my-os-is-debian-12-8-0/30843 "2024-12-18T07:37:14Z")

</div>

---

## [PersistentVolumeClaim (PVC) \`Pending\` स्थिति में फंसी हुई है,](https://discuss.kubernetes.io/t/persistentvolumeclaim-pvc-pending/30856)

<div class="topic-metadata">

**Author:** [@Indogo](https://discuss.kubernetes.io/u/Indogo)\
**Replies:** 2\
**Last updated:** [December 17, 2024, 11:28pm UTC](https://discuss.kubernetes.io/t/persistentvolumeclaim-pvc-pending/30856 "2024-12-17T23:28:49Z")

</div>

मेरी PersistentVolumeClaim (PVC) Pending स्थिति में फंसी हुई है, जबकि एक PersistentVolume (PV) पहले से मौजूद है। इसका समाधान कैसे किया जा सकता है? मैंने एक PVC बनाई है, लेकिन यह Pending स्थिति में अटकी हुई है। जब मैं ku…

---

## [【求助】关于k8s service nodeport与iptables通讯策略及工作原理问题](https://discuss.kubernetes.io/t/k8s-service-nodeport-iptables/30664)

<div class="topic-metadata">

**Author:** [@cscowx](https://discuss.kubernetes.io/u/cscowx)\
**Replies:** 1\
**Last updated:** [November 28, 2024, 1:31am UTC](https://discuss.kubernetes.io/t/k8s-service-nodeport-iptables/30664 "2024-11-28T01:31:48Z")

</div>

环境： k8s master: 192.168.174.110 k8s work-node-01: 192.168.174.125 k8s work-node-02: 192.168.174/126 Kubernetes version: v1.31.2-1.1 Installation method: kubeadm init Host OS: Ubuntu 22.04 LTS CNI and version: cali…

---

## [Pod job type side car container job को completed status में कैसे भेजे?](https://discuss.kubernetes.io/t/pod-job-type-side-car-container-job-completed-status/30453)

<div class="topic-metadata">

**Author:** [@subj](https://discuss.kubernetes.io/u/subj)\
**Replies:** 2\
**Last updated:** [November 10, 2024, 7:48pm UTC](https://discuss.kubernetes.io/t/pod-job-type-side-car-container-job-completed-status/30453 "2024-11-10T19:48:46Z")

</div>

मैं side car container job run कर रहा हु। मैं main application का काम पूरा होने के बावजूद pod running status में ही रह रहा है मैं main application code का काम ख़तम होने के बाद pod को कम्प्लेटेड और एग्जिट होना चाहिए, लेकि…

---

## [K8S cluster deployment Calico error](https://discuss.kubernetes.io/t/k8s-cluster-deployment-calico-error/30267)

<div class="topic-metadata">

**Author:** [@zp\_job](https://discuss.kubernetes.io/u/zp_job)\
**Replies:** 0\
**Last updated:** [October 24, 2024, 6:58am UTC](https://discuss.kubernetes.io/t/k8s-cluster-deployment-calico-error/30267 "2024-10-24T06:58:43Z")

</div>

After creating the K8S cluster, install the CALICO component. Although the CALICO POD is in a running state after installation But upon checking the event, I see the following error message: Readiness probe failed: …

---

## [调度器实现逻辑 applyDefaultHandlers 方法疑问](https://discuss.kubernetes.io/t/applydefaulthandlers/30246)

<div class="topic-metadata">

**Author:** [@die\_be](https://discuss.kubernetes.io/u/die_be)\
**Replies:** 0\
**Last updated:** [October 23, 2024, 12:31pm UTC](https://discuss.kubernetes.io/t/applydefaulthandlers/30246 "2024-10-23T12:31:18Z")

</div>

当我在看 scheduler 的创建流程时，发现这么一个方法： func (sched \*Scheduler) applyDefaultHandlers() { sched.SchedulePod = sched.schedulePod sched.FailureHandler = sched.handleSchedulingFailure } 这样做有什么深意么？

---

## [关于创建pod时报错](https://discuss.kubernetes.io/t/pod/25233)

<div class="topic-metadata">

**Author:** [@kchen](https://discuss.kubernetes.io/u/kchen)\
**Replies:** 1\
**Last updated:** [October 19, 2024, 12:56pm UTC](https://discuss.kubernetes.io/t/pod/25233 "2024-10-19T12:56:14Z")

</div>

任务调度集中在某个时刻，导致k8s：FailedCreatePodSandBox default 60m Warning FailedCreatePodSandBox pod/bzzsxx025936schedule-1673805600-nlhs7 Failed to create pod sandbox: rpc error: code = Unknown desc = failed to set up sandbox conta…

---

## [Ubuntu server microk8s容器启动访问官方网址出现异常，请提供中国区可用的官方网址](https://discuss.kubernetes.io/t/ubuntu-server-microk8s/29955)

<div class="topic-metadata">

**Author:** [@wangyangsheng](https://discuss.kubernetes.io/u/wangyangsheng)\
**Replies:** 2\
**Last updated:** [October 18, 2024, 10:40am UTC](https://discuss.kubernetes.io/t/ubuntu-server-microk8s/29955 "2024-10-18T10:40:33Z")

</div>

日志信息如下所示： ubuntuserver microk8s.daemon-containerd\[27418\]: time=“2024-09-02T06:23:24.890691812Z” level=error msg=“RunPodSandbox for &PodSandboxMetadata{Name:calico-node-j62cv,Uid:bffac951-e693-4467-acb0-d7eeee69727a,Name…

---

## [寻求Kubernetes专家合作进行研究](https://discuss.kubernetes.io/t/kubernetes/29102)

<div class="topic-metadata">

**Author:** [@Zhiyang\_Zhang](https://discuss.kubernetes.io/u/Zhiyang_Zhang)\
**Replies:** 1\
**Last updated:** [August 1, 2024, 4:50pm UTC](https://discuss.kubernetes.io/t/kubernetes/29102 "2024-08-01T16:50:54Z")

</div>

大家好，我们目前正在研究利用 LLM agent 实现自动管理 Kubernetes 集群。 近期我们已经有关于此的一项研究公开在arXiv上（https://arxiv.org/abs/2407.14402）。 我们计划进一步探索这个领域并期待有Kubernetes相关专家能够加入我们，为我们提出宝贵的指导意见。 欢迎社区所有人的留言，期待我们共同努力，对 Kubernetes 生态系统产生积极影响！

---

## [Service responds with 201 created then for some reason ingress responds with 502 error:](https://discuss.kubernetes.io/t/service-responds-with-201-created-then-for-some-reason-ingress-responds-with-502-error/29175)

<div class="topic-metadata">

**Author:** [@Balaganesh\_Murugan](https://discuss.kubernetes.io/u/Balaganesh_Murugan)\
**Replies:** 0\
**Last updated:** [July 27, 2024, 7:26am UTC](https://discuss.kubernetes.io/t/service-responds-with-201-created-then-for-some-reason-ingress-responds-with-502-error/29175 "2024-07-27T07:26:38Z")

</div>

This issue is global and also reproduced from time to time on uat. The root cause is that bff-eapplication makes a request to ms-application-service and request goes through ingress which is based on nginx. ms-applicatio…

---

## [Partial success! kubectl get nodes shows master and 2 of 7 nodes](https://discuss.kubernetes.io/t/partial-success-kubectl-get-nodes-shows-master-and-2-of-7-nodes/28898)

<div class="topic-metadata">

**Author:** [@uek67](https://discuss.kubernetes.io/u/uek67)\
**Replies:** 0\
**Last updated:** [July 4, 2024, 1:14pm UTC](https://discuss.kubernetes.io/t/partial-success-kubectl-get-nodes-shows-master-and-2-of-7-nodes/28898 "2024-07-04T13:14:58Z")

</div>

Hallo liebe Community. ich brauche eure Hilfe mit k3s. Hier mein Problem; I installed k3s following this howto : https://computingforgeeks.com/installing-k3s-on-ubuntu-noble-numbat/ I configured a couple of vm on my pro…

---

## [Die derzeit empfohlene k8s Lösung](https://discuss.kubernetes.io/t/die-derzeit-empfohlene-k8s-losung/27820)

<div class="topic-metadata">

**Author:** [@dalu](https://discuss.kubernetes.io/u/dalu)\
**Replies:** 3\
**Last updated:** [June 14, 2024, 6:42am UTC](https://discuss.kubernetes.io/t/die-derzeit-empfohlene-k8s-losung/27820 "2024-06-14T06:42:55Z")

</div>

Ich habe in den letzten Tagen verschiedene Dinge ausprobiert. In allen Fällen waren es 3 CP 3 Worker Rancher k3s auf CoreOS microk8s auf Ubuntu RKE 1 auf CoreOS ohne SElinux mit Rancher K3s: Resourcenverschwendung B…

---

## [Benötige Unterstützung für Kubernetes](https://discuss.kubernetes.io/t/benotige-unterstutzung-fur-kubernetes/24850)

<div class="topic-metadata">

**Author:** [@PhoenixEX](https://discuss.kubernetes.io/u/PhoenixEX)\
**Replies:** 1\
**Last updated:** [April 19, 2024, 7:42pm UTC](https://discuss.kubernetes.io/t/benotige-unterstutzung-fur-kubernetes/24850 "2024-04-19T19:42:57Z")

</div>

Hallo, ich bin gerade dabei, mir Tutorials über Kubernetes anzugucken. Das heisst, dass ich in Bezug auf dieses Thema kein Vorwissen / Wissen habe. Aus diesem Grund habe ich mir folgendes Video angeguckt und soweit au…

---

## [Kubectl 怎么实现联合查询](https://discuss.kubernetes.io/t/kubectl/27961)

<div class="topic-metadata">

**Author:** [@mongoliaredmountain](https://discuss.kubernetes.io/u/mongoliaredmountain)\
**Replies:** 0\
**Last updated:** [April 19, 2024, 7:21am UTC](https://discuss.kubernetes.io/t/kubectl/27961 "2024-04-19T07:21:54Z")

</div>

kubectl 怎么实现联合查询，例如：查询一：kubectl get no -L \*\*\*\* 获得节点的某一个 label 值，查询二：kubectl get po -n \*\*\* -o wide 获得节点的名称，如何通过一条 kubectl 查询二关联查询一，获得 pod 所关联 nodes 的 label

[Next page](https://discuss.kubernetes.io/c/regional-discussions/15.md?page=1)
