About "make bazel-build" ERROR

#1

Hello, When I run "about “bazel-build”, I got this:

$ make bazel-build
INFO: Invocation ID: deabddb2-2166-411c-8dce-88e62952542c
ERROR: /Users/coral/workspaces/kubernetes-1.14/src/kubernetes/build/BUILD:63:2: Configurable attribute "bundle" doesn't match this configuration (would a default condition help?).
Conditions checked:
 @io_bazel_rules_go//go/platform:linux_amd64
 @io_bazel_rules_go//go/platform:linux_arm
 @io_bazel_rules_go//go/platform:linux_arm64
 @io_bazel_rules_go//go/platform:linux_ppc64le
 @io_bazel_rules_go//go/platform:linux_s390x
ERROR: Analysis of target '//build:push-kube-scheduler' failed; build aborted:

/Users/coral/workspaces/kubernetes-1.14/src/kubernetes/build/BUILD:63:2: Configurable attribute "bundle" doesn't match this configuration (would a default condition help?).
Conditions checked:
 @io_bazel_rules_go//go/platform:linux_amd64
 @io_bazel_rules_go//go/platform:linux_arm
 @io_bazel_rules_go//go/platform:linux_arm64
 @io_bazel_rules_go//go/platform:linux_ppc64le
 @io_bazel_rules_go//go/platform:linux_s390x
INFO: Elapsed time: 10.072s
INFO: 0 processes.
FAILED: Build did NOT complete successfully (4740 packages loaded, 2371 targets configured)
    currently loading: @local_config_sh// ... (3 packages)
    Fetching @local_config_cc; Restarting.
make: *** [bazel-build] Error 1

about versions:
k8s version: 1.14
bazel version: 0.22.0
Darwin Kernel Version: 16.7.0

Thanks everyone.

0 Likes