# Error getting ClusterInformation - Forbidden \[solved\]

**URL:** <https://discuss.kubernetes.io/t/error-getting-clusterinformation-forbidden-solved/14843>\
**Category:** microk8s\
**Created:** [February 16, 2021, 9:54am UTC](https://discuss.kubernetes.io/t/error-getting-clusterinformation-forbidden-solved/14843 "2021-02-16T09:54:02Z")\
**Posts on this page:** 1\
**Showing post:** 4

<div class="post-metadata">

**Author:** ![laplasz](https://sea2.discourse-cdn.com/flex016/user_avatar/discuss.kubernetes.io/laplasz/32/6975_2.png) [@laplasz](https://discuss.kubernetes.io/u/laplasz)\
**Post date:** [February 16, 2021, 3:18pm UTC](https://discuss.kubernetes.io/t/error-getting-clusterinformation-forbidden-solved/14843/4 "2021-02-16T15:18:32Z")

</div>

is it possible that microk8s using the system proxy? how can I disable proxy settings for microk8s?  
yes, that was it  
i had to update `/etc/environment` with NO\_PROXY for microk8s IPs

> [@Installing behind a proxy](https://discuss.kubernetes.io/t/installing-behind-a-proxy/11275):
>
> Configuring the proxy environment variables MicroK8s packages a number of utilities (eg curl, helm) that may need to fetch resources from the internet. Having our environment (/etc/environment) properly configured allows such utilities to function properly. We need to configure HTTPS\_PROXY, HTTP\_PROXY, https\_proxy and http\_proxy variables with the proxy endpoint as well as NO\_PROXY and no\_proxy with the IP ranges the pods and services occupy. For instance assuming our proxy is at http://squid.internal:3128, /etc/environment should set the following environment variables: HTTPS\_PROXY=http://sq…

---

_[View the full topic](https://discuss.kubernetes.io/t/error-getting-clusterinformation-forbidden-solved/14843)._
