Etcd V2 support

Hi,

can someone tell me if etcd v2 API will continue to be supported after upgrade to v3.x+ ?

Thank you

Cluster information:

Kubernetes version:
Cloud being used: (put bare-metal if not on a public cloud)
Installation method:
Host OS:
CNI and version:
CRI and version: