# Filed to pull image

**URL:** <https://discuss.kubernetes.io/t/filed-to-pull-image/30594>\
**Category:** General Discussions\
**Created:** [November 22, 2024, 3:44am UTC](https://discuss.kubernetes.io/t/filed-to-pull-image/30594 "2024-11-22T03:44:35Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![m\_pahlevanzadeh](https://sea2.discourse-cdn.com/flex016/user_avatar/discuss.kubernetes.io/m_pahlevanzadeh/32/10755_2.png) [@m\_pahlevanzadeh](https://discuss.kubernetes.io/u/m_pahlevanzadeh)\
**Post date:** [November 22, 2024, 3:44am UTC](https://discuss.kubernetes.io/t/filed-to-pull-image/30594/1 "2024-11-22T03:44:35Z")

</div>

I have the followin command:

```auto
kubeadm config images pull

```

After the given command, I get the following messages:

```auto
I1122 07:08:32.416853 526776 version.go:256] remote version is much newer: v1.31.3; falling back to: stable-1.30
W1122 07:08:32.730982 526776 version.go:104] could not fetch a Kubernetes version from the internet: unable to get URL "https://dl.k8s.io/release/stable-1.30.txt": Get "https://dl.k8s.io/release/stable-1.30.txt": EOF
W1122 07:08:32.731054 526776 version.go:105] falling back to the local client version: v1.30.6
failed to pull image "registry.k8s.io/kube-apiserver:v1.30.6": output: E1122 07:08:32.911072 526819 log.go:32] "PullImage from image service failed" err="rpc error: code = Unknown desc = failed to pull and unpack image \"registry.k8s.io/kube-apiserver:v1.30.6\": failed to resolve reference \"registry.k8s.io/kube-apiserver:v1.30.6\": failed to do request: Head \"https://registry.k8s.io/v2/kube-apiserver/manifests/v1.30.6\": unexpected EOF" image="registry.k8s.io/kube-apiserver:v1.30.6"
time="2024-11-22T07:08:32+03:30" level=fatal msg="pulling image: failed to pull and unpack image \"registry.k8s.io/kube-apiserver:v1.30.6\": failed to resolve reference \"registry.k8s.io/kube-apiserver:v1.30.6\": failed to do request: Head \"https://registry.k8s.io/v2/kube-apiserver/manifests/v1.30.6\": unexpected EOF"
, error: exit status 1
To see the stack trace of this error execute with --v=5 or higher

```

How to do I solve?

---

<div class="post-metadata">

**Author:** ![TaoYu](https://sea2.discourse-cdn.com/flex016/user_avatar/discuss.kubernetes.io/taoyu/32/12178_2.png) [@TaoYu](https://discuss.kubernetes.io/u/TaoYu)\
**Post date:** [November 25, 2024, 10:26am UTC](https://discuss.kubernetes.io/t/filed-to-pull-image/30594/2 "2024-11-25T10:26:03Z")

</div>

You can try check address [registry.k8s.io](http://registry.k8s.io) of the internet by tools curl if can access it.
