# Getting Error while initializing kubeadm

**URL:** <https://discuss.kubernetes.io/t/getting-error-while-initializing-kubeadm/26240>\
**Category:** General Discussions\
**Created:** [November 28, 2023, 8:06pm UTC](https://discuss.kubernetes.io/t/getting-error-while-initializing-kubeadm/26240 "2023-11-28T20:06:52Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![ashish\_sood1](https://avatars.discourse-cdn.com/v4/letter/a/c67d28/32.png) [@ashish\_sood1](https://discuss.kubernetes.io/u/ashish_sood1)\
**Post date:** [November 28, 2023, 8:06pm UTC](https://discuss.kubernetes.io/t/getting-error-while-initializing-kubeadm/26240/1 "2023-11-28T20:06:52Z")

</div>

Hi Everyone,

I am getting an error during initializing the kubeadm command, below is the output.

```auto
root@master:~# kubeadm init --apiserver-advertise-address 10.0.0.100 --pod-network-cidr 172.16.0.0/16
W1128 20:00:01.930178 3150 version.go:104] could not fetch a Kubernetes version from the internet: unable to get URL "https://dl.k8s.io/release/stable-1.txt": Get "https://cdn.dl.k8s.io/release/stable-1.txt": tls: failed to verify certificate: x509: certificate signed by unknown authority
W1128 20:00:01.930299 3150 version.go:105] falling back to the local client version: v1.28.0
[init] Using Kubernetes version: v1.28.0
[preflight] Running pre-flight checks
error execution phase preflight: [preflight] Some fatal errors occurred:
        [ERROR CRI]: container runtime is not running: output: E1128 20:00:01.995182 3159 remote_runtime.go:616] "Status from runtime service failed" err="rpc error: code = Unavailable desc = connection error: desc = \"transport: Error while dialing dial unix /var/run/containerd/containerd.sock: connect: no such file or directory\""
time="2023-11-28T20:00:01Z" level=fatal msg="getting status of runtime: rpc error: code = Unavailable desc = connection error: desc = \"transport: Error while dialing dial unix /var/run/containerd/containerd.sock: connect: no such file or directory\""
, error: exit status 1
[preflight] If you know what you are doing, you can make a check non-fatal with `--ignore-preflight-errors=...`
To see the stack trace of this error execute with --v=5 or higher
root@master:~#
root@master:~#
root@master:~#
root@master:~# kubeadm config images pull
W1128 20:00:09.844515 3186 version.go:104] could not fetch a Kubernetes version from the internet: unable to get URL "https://dl.k8s.io/release/stable-1.txt": Get "https://cdn.dl.k8s.io/release/stable-1.txt": tls: failed to verify certificate: x509: certificate signed by unknown authority
W1128 20:00:09.844670 3186 version.go:105] falling back to the local client version: v1.28.0
failed to pull image "registry.k8s.io/kube-apiserver:v1.28.0": output: E1128 20:00:10.104265 3218 remote_image.go:171] "PullImage from image service failed" err="rpc error: code = Unavailable desc = connection error: desc = \"transport: Error while dialing dial unix /var/run/containerd/containerd.sock: connect: no such file or directory\"" image="registry.k8s.io/kube-apiserver:v1.28.0"
time="2023-11-28T20:00:10Z" level=fatal msg="pulling image: rpc error: code = Unavailable desc = connection error: desc = \"transport: Error while dialing dial unix /var/run/containerd/containerd.sock: connect: no such file or directory\""
, error: exit status 1
To see the stack trace of this error execute with --v=5 or higher
root@master:~#

```

OS

```auto
PRETTY_NAME="Ubuntu 22.04.3 LTS"
NAME="Ubuntu"
VERSION_ID="22.04"
VERSION="22.04.3 LTS (Jammy Jellyfish)"
VERSION_CODENAME=jammy

```

Kube version

```auto
root@master:~# kubeadm version
kubeadm version: &version.Info{Major:"1", Minor:"28", GitVersion:"v1.28.0", GitCommit:"855e7c48de7388eb330da0f8d9d2394ee818fb8d", GitTreeState:"clean", BuildDate:"2023-08-15T10:20:15Z", GoVersion:"go1.20.7", Compiler:"gc", Platform:"linux/amd64"}
root@master:~#
root@master:~#
root@master:~#
root@master:~# kubectl version
Client Version: v1.28.0
Kustomize Version: v5.0.4-0.20230601165947-6ce0bf390ce3
The connection to the server localhost:8080 was refused - did you specify the right host or port?

```

I can connect to internet via Nat interface

```auto
root@master:~# ping www.google.com
PING www.google.com (142.250.193.100) 56(84) bytes of data.
64 bytes from maa05s24-in-f4.1e100.net (142.250.193.100): icmp_seq=1 ttl=128 time=13.5 ms
64 bytes from maa05s24-in-f4.1e100.net (142.250.193.100): icmp_seq=2 ttl=128 time=14.1 ms
^C
--- www.google.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1002ms
rtt min/avg/max/mdev = 13.485/13.786/14.088/0.301 ms

```

Regards,  
Ashish

---

<div class="post-metadata">

**Author:** ![ashish\_sood1](https://avatars.discourse-cdn.com/v4/letter/a/c67d28/32.png) [@ashish\_sood1](https://discuss.kubernetes.io/u/ashish_sood1)\
**Post date:** [November 29, 2023, 5:53am UTC](https://discuss.kubernetes.io/t/getting-error-while-initializing-kubeadm/26240/2 "2023-11-29T05:53:07Z")

</div>

Hi Community  
any update?

---

<div class="post-metadata">

**Author:** ![gaoxiuyang](https://sea2.discourse-cdn.com/flex016/user_avatar/discuss.kubernetes.io/gaoxiuyang/32/15069_2.png) [@gaoxiuyang](https://discuss.kubernetes.io/u/gaoxiuyang)\
**Post date:** [May 26, 2024, 1:30pm UTC](https://discuss.kubernetes.io/t/getting-error-while-initializing-kubeadm/26240/3 "2024-05-26T13:30:49Z")

</div>

hello  
May I ask if there has been any progress on this issue? I have also encountered the same problem
