# How to apply --config flag to update kubelet-config.json

**URL:** https://discuss.kubernetes.io/t/how-to-apply-config-flag-to-update-kubelet-config-json/23428
**Category:** General Discussions
**Created:** [March 11, 2023, 1:04pm UTC](https://discuss.kubernetes.io/t/how-to-apply-config-flag-to-update-kubelet-config-json/23428 "2023-03-11T13:04:05Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Sunwoo\_Jang](https://sea2.discourse-cdn.com/flex016/user_avatar/discuss.kubernetes.io/sunwoo_jang/32/12027_2.png) [@Sunwoo\_Jang](https://discuss.kubernetes.io/u/Sunwoo_Jang)
#### Post date: [March 11, 2023, 1:04pm UTC](https://discuss.kubernetes.io/t/how-to-apply-config-flag-to-update-kubelet-config-json/23428/1 "2023-03-11T13:04:05Z")

</div>

I have EKS cluster and want to enable Unsafe Sysctls [1]. At first, I try to use `kubelet --allowed-unsafe-sysctls 'net.ipv4.tcp_keepalive_intvl'` on worker node. But, following error occured because it’s deperecated [2].

```auto
Flag --allowed-unsafe-sysctls has been deprecated, This parameter should be set via the config file specified by the Kubelet's --config flag. See https://kubernetes.io/docs/tasks/administer-cluster/kube

```

Thus, I tried `kubelet --config config.yaml`. But the error occurred.

```auto
I0311 13:00:55.484190 5534 exclusion.go:84] No environment variable set, using default exclusion rules
E0311 13:00:55.484226 5534 exclusion.go:94] Invalid webhook admission exclusion rule, scope not set
E0311 13:00:55.484235 5534 exclusion.go:94] Invalid webhook admission exclusion rule, scope not set
I0311 13:00:55.899202 5534 server.go:446] "Kubelet version" kubeletVersion="v1.23.16-eks-48e63af"
I0311 13:00:55.899690 5534 server.go:606] "Standalone mode, no API client"
E0311 13:00:55.899842 5534 server.go:302] "Failed to run kubelet" err="failed to run Kubelet: no client provided, cannot use webhook authentication"

```

\<config.yaml\>

```auto
apiVersion: kubelet.config.k8s.io/v1beta1
kind: KubeletConfiguration
allowedUnsafeSysctls:
- "net.ipv4.tcp_keepalive_intvl"

```

What did i miss? I would appreciate if you could give me any advice.

kubelet version: v1.23.16-eks-48e63af  
container runtime: Docker

[1] [Using sysctls in a Kubernetes Cluster | Kubernetes](https://kubernetes.io/docs/tasks/administer-cluster/sysctl-cluster/)  
[2] [kubelet | Kubernetes](https://kubernetes.io/docs/reference/command-line-tools-reference/kubelet/)

---

<div class="post-metadata">

### Author: ![Chris\_Berardi](https://sea2.discourse-cdn.com/flex016/user_avatar/discuss.kubernetes.io/chris_berardi/32/12262_2.png) [@Chris\_Berardi](https://discuss.kubernetes.io/u/Chris_Berardi)
#### Post date: [April 12, 2023, 1:31pm UTC](https://discuss.kubernetes.io/t/how-to-apply-config-flag-to-update-kubelet-config-json/23428/2 "2023-04-12T13:31:42Z")

</div>

Did you ever resolve this? I am getting the same error with environment variable/invalid webhook.
