# Installation issue in Win11 (couldn't get current server API group list)

**URL:** <https://discuss.kubernetes.io/t/installation-issue-in-win11-couldnt-get-current-server-api-group-list/27977>\
**Category:** microk8s\
**Created:** [April 20, 2024, 9:50pm UTC](https://discuss.kubernetes.io/t/installation-issue-in-win11-couldnt-get-current-server-api-group-list/27977 "2024-04-20T21:50:22Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![mmcc](https://avatars.discourse-cdn.com/v4/letter/m/c5a1d2/32.png) [@mmcc](https://discuss.kubernetes.io/u/mmcc)\
**Post date:** [April 20, 2024, 9:50pm UTC](https://discuss.kubernetes.io/t/installation-issue-in-win11-couldnt-get-current-server-api-group-list/27977/1 "2024-04-20T21:50:22Z")

</div>

I’m installing microk8s on Win11 Home edition with VirtualBox VM. The installation runs without errors, but running any kubectl commands results in an error:

> microk8s kubectl get all --all-namespaces  
> E0420 21:47:37.787111 19992 memcache.go:265] couldn’t get current server API group list: Get “[https://10.0.2.15:16443/api?timeout=32s](https://10.0.2.15:16443/api?timeout=32s)”: dial tcp 10.0.2.15:16443: connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.  
> E0420 21:47:58.791039 19992 memcache.go:265] couldn’t get current server API group list: Get “[https://10.0.2.15:16443/api?timeout=32s](https://10.0.2.15:16443/api?timeout=32s)”: dial tcp 10.0.2.15:16443: connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.  
> E0420 21:48:19.795631 19992 memcache.go:265] couldn’t get current server API group list: Get “[https://10.0.2.15:16443/api?timeout=32s](https://10.0.2.15:16443/api?timeout=32s)”: dial tcp 10.0.2.15:16443: connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.  
> E0420 21:48:40.798005 19992 memcache.go:265] couldn’t get current server API group list: Get “[https://10.0.2.15:16443/api?timeout=32s](https://10.0.2.15:16443/api?timeout=32s)”: dial tcp 10.0.2.15:16443: connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.  
> E0420 21:49:01.802279 19992 memcache.go:265] couldn’t get current server API group list: Get “[https://10.0.2.15:16443/api?timeout=32s](https://10.0.2.15:16443/api?timeout=32s)”: dial tcp 10.0.2.15:16443: connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.  
> Unable to connect to the server: dial tcp 10.0.2.15:16443: connectex: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

I’ve repeated the install several times and the same failure occurs.

---

<div class="post-metadata">

**Author:** ![mmcc](https://avatars.discourse-cdn.com/v4/letter/m/c5a1d2/32.png) [@mmcc](https://discuss.kubernetes.io/u/mmcc)\
**Post date:** [April 20, 2024, 10:18pm UTC](https://discuss.kubernetes.io/t/installation-issue-in-win11-couldnt-get-current-server-api-group-list/27977/2 "2024-04-20T22:18:04Z")

</div>

Some additional info:

> microk8s kubectl config view  
> apiVersion: v1  
> clusters:

- cluster:  
certificate-authority-data: DATA+OMITTED  
server: [https://10.0.2.15:16443](https://10.0.2.15:16443)  
name: microk8s-cluster  
contexts:
- context:  
cluster: microk8s-cluster  
user: admin  
name: microk8s  
current-context: microk8s  
kind: Config  
preferences: {}  
users:
- name: admin  
user:  
client-certificate-data: DATA+OMITTED  
client-key-data: DATA+OMITTED

> multipass info --all  
> Name: microk8s-vm  
> State: Running  
> IPv4: 10.1.254.64  
> Release: Ubuntu 22.04.4 LTS  
> Image hash: bd476bc534ba (Ubuntu 22.04 LTS)  
> CPU(s): 2  
> Load: 0.00 0.19 0.19  
> Disk usage: 3.7GiB out of 48.4GiB  
> Memory usage: 786.4MiB out of 3.8GiB  
> Mounts: –

---

<div class="post-metadata">

**Author:** ![mmcc](https://avatars.discourse-cdn.com/v4/letter/m/c5a1d2/32.png) [@mmcc](https://discuss.kubernetes.io/u/mmcc)\
**Post date:** [April 21, 2024, 1:13am UTC](https://discuss.kubernetes.io/t/installation-issue-in-win11-couldnt-get-current-server-api-group-list/27977/3 "2024-04-21T01:13:44Z")

</div>

Pinging the host from the VM works:

> multipass exec -n microk8s-vm – ping 10.1.254.64  
> PING 10.1.254.64 (10.1.254.64) 56(84) bytes of data.  
> 64 bytes from 10.1.254.64: icmp\_seq=1 ttl=64 time=0.027 ms  
> 64 bytes from 10.1.254.64: icmp\_seq=2 ttl=64 time=0.032 ms  
> 64 bytes from 10.1.254.64: icmp\_seq=3 ttl=64 time=0.037 ms  
> 64 bytes from 10.1.254.64: icmp\_seq=4 ttl=64 time=0.036 ms

But pinging the VM from the host does not.

---

<div class="post-metadata">

**Author:** ![mmcc](https://avatars.discourse-cdn.com/v4/letter/m/c5a1d2/32.png) [@mmcc](https://discuss.kubernetes.io/u/mmcc)\
**Post date:** [April 21, 2024, 5:21pm UTC](https://discuss.kubernetes.io/t/installation-issue-in-win11-couldnt-get-current-server-api-group-list/27977/4 "2024-04-21T17:21:53Z")

</div>

Looks like VirtualBox is the issue. Upgraded to Win 11 Pro and setup Hyper-V. Seems to be working now.
