# Kubeadm init --pod-network-cidr=10.244.0.0/16 Error (Kubernetes version: v1.13.3)

**URL:** <https://discuss.kubernetes.io/t/kubeadm-init-pod-network-cidr-10-244-0-0-16-error-kubernetes-version-v1-13-3/4634>\
**Category:** General Discussions\
**Created:** [February 12, 2019, 2:25am UTC](https://discuss.kubernetes.io/t/kubeadm-init-pod-network-cidr-10-244-0-0-16-error-kubernetes-version-v1-13-3/4634 "2019-02-12T02:25:55Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![osab1](https://avatars.discourse-cdn.com/v4/letter/o/858c86/32.png) [@osab1](https://discuss.kubernetes.io/u/osab1)\
**Post date:** [February 12, 2019, 2:25am UTC](https://discuss.kubernetes.io/t/kubeadm-init-pod-network-cidr-10-244-0-0-16-error-kubernetes-version-v1-13-3/4634/1 "2019-02-12T02:25:55Z")

</div>

Hello,  
I am getting error when trying to run “kubeadm init” & “docker run” command. It can connect to internet by using proxy server. “yum install” works fine. Following error:

```
# docker run hello-world
Unable to find image 'hello-world:latest' locally
docker: Error response from daemon: Get https://registry-1.docker.io/v2/: dial tcp: lookup registry-1.docker.io on [::1]:53: read udp [::1]:52688-&gt;[::1]:53: read: connection refused.
See 'docker run --help'.

```

# 

```
# kubeadm init --pod-network-cidr=10.244.0.0/16
I0211 16:25:01.176120 102262 version.go:94] could not fetch a Kubernetes version from the internet: unable to get URL "https://dl.k8s.io/release/stable-1.txt": Get https://dl.k8s.io/release/stable-1.txt: x509: certificate signed by unknown authority
I0211 16:25:01.176204 102262 version.go:95] falling back to the local client version: v1.13.3
[init] Using Kubernetes version: v1.13.3
[preflight] Running pre-flight checks
```

---

<div class="post-metadata">

**Author:** ![ralph](https://sea2.discourse-cdn.com/flex016/user_avatar/discuss.kubernetes.io/ralph/32/2213_2.png) [@ralph](https://discuss.kubernetes.io/u/ralph)\
**Post date:** [February 13, 2019, 6:45pm UTC](https://discuss.kubernetes.io/t/kubeadm-init-pod-network-cidr-10-244-0-0-16-error-kubernetes-version-v1-13-3/4634/2 "2019-02-13T18:45:29Z")

</div>

It looks like a dns issue. From the node that you run kubeadm init on does curl [https://storage.googleapis.com/kubernetes-release/release/stable-1.txt](https://storage.googleapis.com/kubernetes-release/release/stable-1.txt) or dig [storage.googleapis.com](http://storage.googleapis.com) work for you?
