# Kubernetes via VPN

**URL:** <https://discuss.kubernetes.io/t/kubernetes-via-vpn/17762>\
**Category:** General Discussions\
**Created:** [October 13, 2021, 11:07am UTC](https://discuss.kubernetes.io/t/kubernetes-via-vpn/17762 "2021-10-13T11:07:07Z")\
**Posts on this page:** 1\
**Showing post:** 5

<div class="post-metadata">

**Author:** ![cortex3](https://avatars.discourse-cdn.com/v4/letter/c/a5b964/32.png) [@cortex3](https://discuss.kubernetes.io/u/cortex3)\
**Post date:** [October 29, 2021, 8:26am UTC](https://discuss.kubernetes.io/t/kubernetes-via-vpn/17762/5 "2021-10-29T08:26:39Z")

</div>

This is definitely possible.  
You just have to set the node-ip parameter either in the kubeadm config or inside kubelet.

Currently I’m still struggling to build a setup with multiple masters tho. See my thread for more info:

> [@Kubeadm HA setup behind VPN](https://discuss.kubernetes.io/t/kubeadm-ha-setup-behind-vpn/17926):
>
> I’ve been trying to setup a HA Kubernetes cluster behind a VPN for days. It works with one master and 2 workers but i fail to add an additional master. The kubeadm join command for the second master fails with: I1028 14:43:11.117358 20750 etcd.go:468] Failed to get etcd status for https://PUBLIC-IP:2379: failed to dial endpoint https://PUBLIC-IP:2379 with maintenance client: context deadline exceeded It is supposed to use the private IP here but it should also be able to reach the public-ip. I noticed that using node-ip is insufficient since etcd chooses to use the public ip automatica…

I couldn’t find much info on if using a VPN is best practice and what alternatives there are.

---

_[View the full topic](https://discuss.kubernetes.io/t/kubernetes-via-vpn/17762)._
