# Managed NGINX SSL Failure on AKS

**URL:** <https://discuss.kubernetes.io/t/managed-nginx-ssl-failure-on-aks/30958>\
**Category:** General Discussions\
**Created:** [December 27, 2024, 12:53pm UTC](https://discuss.kubernetes.io/t/managed-nginx-ssl-failure-on-aks/30958 "2024-12-27T12:53:00Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![DHAWAL\_MATHUR](https://sea2.discourse-cdn.com/flex016/user_avatar/discuss.kubernetes.io/dhawal_mathur/32/16550_2.png) [@DHAWAL\_MATHUR](https://discuss.kubernetes.io/u/DHAWAL_MATHUR)\
**Post date:** [December 27, 2024, 12:53pm UTC](https://discuss.kubernetes.io/t/managed-nginx-ssl-failure-on-aks/30958/1 "2024-12-27T12:53:00Z")

</div>

Hi All,

Need help please in a issue

I am using AKS and have installed managed NGINX on same using Application Routing add On

[Azure Kubernetes Service (AKS) managed NGINX ingress with the application routing add-on - Azure Kubernetes Service | Microsoft Learn](https://learn.microsoft.com/en-us/azure/aks/app-routing).

But Backend NGINX Pods are showing below error. Could anyone please help, what could be root cause for same

W1225 06:38:01.166185 7 client\_config.go:659] Neither --kubeconfig nor --master was specified. Using the inClusterConfig. This might not work.  
I1225 06:38:01.166325 7 main.go:205] “Creating API client” host=“[https://10.0.0.1:443](https://10.0.0.1:443)”  
F1225 06:40:59.160348 7 main.go:262] Error while initiating a connection to the Kubernetes API server. This could mean the cluster is misconfigured (e.g. it has invalid API server certificates or Service Accounts configuration). Reason: Get "[https://10.0.0.1:443/version":](https://10.0.0.1:443/version%22:) EOF  
Refer to the troubleshooting guide for more information: [Troubleshooting - Ingress-Nginx Controller](https://kubernetes.github.io/ingress-nginx/troubleshooting/)

### Cluster information:

Kubernetes version: 1.29.7  
Cloud being used: AKS  
Installation method: Managed AKS  
Host OS: Linux  
CNI and version: Azure CNI  
CRI and version: containerd://1.7.23-1

You can format your yaml by highlighting it and pressing Ctrl-Shift-C, it will make your output easier to read.
