# Metallb layer 2 access denied

**URL:** <https://discuss.kubernetes.io/t/metallb-layer-2-access-denied/7208>\
**Category:** General Discussions\
**Tags:** metallb\
**Created:** [July 18, 2019, 4:58pm UTC](https://discuss.kubernetes.io/t/metallb-layer-2-access-denied/7208 "2019-07-18T16:58:53Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![elhamahmadloo](https://avatars.discourse-cdn.com/v4/letter/e/6de8d8/32.png) [@elhamahmadloo](https://discuss.kubernetes.io/u/elhamahmadloo)\
**Post date:** [July 18, 2019, 4:58pm UTC](https://discuss.kubernetes.io/t/metallb-layer-2-access-denied/7208/1 "2019-07-18T16:58:53Z")

</div>

Hello everyone

i have one master and two nodes , my cluster is bare metal kubernetes , for having a loadbalancer i have choosed metallb . for first step i decided to use layer2 . every thing look great as my service got its external ip from the ip pool. i have made the ip pool in the same network of the nodes . i configed my kubernetes just like all manual which are in the internet ( choosing nginx image for creating deployment and choosing Loadbalancer for the service type and also port 80 as the container port).

Now when i curl [http://ExternalIP](http://ExternalIP) from my master or other node , nginx responses.

But the problem is that , there is no access to the external ip from outside of my cluser . i also have no access to the external ip from the same network ips.

when i check the logs there is some “ARP responder” logs , but there is no access to [http://Externalip:80](http://Externalip:80)

the firewall service is stoped in my master and all nodes .

i have also enable proxy\_arp in my master and nodes .

So …please tell me …“How can i access my metallb layer2 loadbalancer with external ip from outside of my cluser ?”

 ![image](https://us1.discourse-cdn.com/flex016/uploads/kubernetes/original/2X/f/fb604301e1fa34d63b4874318dbb85687fa92fb1.png)  
 ![image](https://us1.discourse-cdn.com/flex016/uploads/kubernetes/original/2X/f/f03ab60fee2d0e99ab52034f64b777c40ad3fbe3.png)  
 ![image](https://us1.discourse-cdn.com/flex016/uploads/kubernetes/original/2X/4/4269fcb4e69a28e2381c61cbdc3ab0ee183aa32c.png)  
 ![image](https://us1.discourse-cdn.com/flex016/uploads/kubernetes/original/2X/8/8a4c80512b6e39ab701f23eac33125529dd59938.png)  
 ![image](https://us1.discourse-cdn.com/flex016/uploads/kubernetes/original/2X/8/895e1ad3ac3f7059b27a757588733851c1a6c958.png)  
 ![image](https://us1.discourse-cdn.com/flex016/uploads/kubernetes/original/2X/2/231d71f659fc9dca010032701679d77fedf8ad71.png)  
 ![image](https://us1.discourse-cdn.com/flex016/uploads/kubernetes/original/2X/8/8ebe04676acd93ad700f9a48a41a5c764f680633.png)

---

<div class="post-metadata">

**Author:** ![mrbobbytables](https://sea2.discourse-cdn.com/flex016/user_avatar/discuss.kubernetes.io/mrbobbytables/32/7_2.png) [@mrbobbytables](https://discuss.kubernetes.io/u/mrbobbytables)\
**Post date:** [July 18, 2019, 6:11pm UTC](https://discuss.kubernetes.io/t/metallb-layer-2-access-denied/7208/2 "2019-07-18T18:11:52Z")

</div>

Is the externalIP pool in the same IP range as the hosts? The external IP pool **MUST** be routable on the host’s network for it to function.

---

<div class="post-metadata">

**Author:** ![elhamahmadloo](https://avatars.discourse-cdn.com/v4/letter/e/6de8d8/32.png) [@elhamahmadloo](https://discuss.kubernetes.io/u/elhamahmadloo)\
**Post date:** [July 20, 2019, 5:22am UTC](https://discuss.kubernetes.io/t/metallb-layer-2-access-denied/7208/3 "2019-07-20T05:22:38Z")

</div>

hi  
thanks for your response , yes , as above photos show , my external ip , has the same range ip as the master and nodes .

---

<div class="post-metadata">

**Author:** ![elhamahmadloo](https://avatars.discourse-cdn.com/v4/letter/e/6de8d8/32.png) [@elhamahmadloo](https://discuss.kubernetes.io/u/elhamahmadloo)\
**Post date:** [July 20, 2019, 7:28am UTC](https://discuss.kubernetes.io/t/metallb-layer-2-access-denied/7208/4 "2019-07-20T07:28:14Z")

</div>

you were right . one of my nodes was in different range and vlan , when i changed node ip , my problem has been solved , thanks
