# Microk8s cluster stuck after installing OLM 0.14.1

**URL:** <https://discuss.kubernetes.io/t/microk8s-cluster-stuck-after-installing-olm-0-14-1/12094>\
**Category:** microk8s\
**Created:** [July 31, 2020, 4:55pm UTC](https://discuss.kubernetes.io/t/microk8s-cluster-stuck-after-installing-olm-0-14-1/12094 "2020-07-31T16:55:05Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![TristanStanic](https://sea2.discourse-cdn.com/flex016/user_avatar/discuss.kubernetes.io/tristanstanic/32/5148_2.png) [@TristanStanic](https://discuss.kubernetes.io/u/TristanStanic)\
**Post date:** [July 31, 2020, 4:55pm UTC](https://discuss.kubernetes.io/t/microk8s-cluster-stuck-after-installing-olm-0-14-1/12094/1 "2020-07-31T16:55:05Z")

</div>

Hi,

Using microk8s 1.18.6 stable. I tried to run this execise [Cassandra in Kubernetes](https://github.com/DataStax-Academy/cassandra-workshop-series/blob/master/week5-Cass-in-k8s/README_METRICS_DSE.MD). Part of the requirement is to install [Operator Lifecycle Manager](https://github.com/operator-framework/operator-lifecycle-manager) version 0.14.1 using [this script](https://github.com/DataStax-Academy/cassandra-workshop-series/blob/master/week5-Cass-in-k8s/prometheus_grafana/install-olm.sh)

Once I installed OLM 0.14.1, I noticed that the microk8s has significantly slowed down. Took about 2 hours for the operator pod to be stabilized in running status. A few hours later, all pods fails with an error like this (seen by `kubectl describe pod the-pod-id`)

```auto
  Warning FailedMount 17m (x140 over 4h48m) kubelet, silverbullet MountVolume.SetUp failed for volume "cass-operator-token-fjmnd" : failed to sync secret cache: timed out waiting for the condition

OR this

Events:
  Type Reason Age From Message
  ---- ------ ---- ---- -------
  Warning FailedScheduling 4m21s (x39 over 19m) default-scheduler 0/1 nodes are available: 1 node(s) had taint {node.kubernetes.io/not-ready: }, that the pod didn't tolerate.
  Warning FailedMount 18s (x8 over 89s) kubelet, silverbullet MountVolume.SetUp failed for volume "grafana-operator-token-p45h6" : failed to sync secret cache: timed out waiting for the condition

```

Attempting to cleanup, I tried to delete all the resources created by the OLM operators and also delete the namespace which was used for the exercise. But the namespaces are stuck in a `Terminating` status.

```auto
$ kubectl get namespaces

NAME STATUS AGE
cass-operator Terminating 11h
olm Terminating 9h
operators Terminating 9h
... skip remaining Active namespaces ...

```

QUESTION: is there a way to get microk8s cluster back to its normal working status and to finish the deletion of the namespaces?

I have the tarball of [microk8s inspect (Google Drive)](https://drive.google.com/file/d/1o10Q4EnlNziO4AVTaFFHrVK3a26IfK1O/view?usp=sharing) can you suggest a proper way to submit attachment in this board? Or would it be better I file an issue in [https://github.com/ubuntu/microk8s/issues](https://github.com/ubuntu/microk8s/issues) and attach the inspection report there?

---

<div class="post-metadata">

**Author:** ![balchua1](https://sea2.discourse-cdn.com/flex016/user_avatar/discuss.kubernetes.io/balchua1/32/5372_2.png) [@balchua1](https://discuss.kubernetes.io/u/balchua1)\
**Post date:** [July 31, 2020, 10:28pm UTC](https://discuss.kubernetes.io/t/microk8s-cluster-stuck-after-installing-olm-0-14-1/12094/2 "2020-07-31T22:28:09Z")

</div>

OLM requires to have rbac enabled. I remember an issue regarding OLM. Usually namespaces stuck in `Terminating` state is caused by `CRD`s or `Apiservice` which are not deleted.  
If it is ok for you to do `sudo snap remove microk8s` then `sudo snap install microk8s --channel=<the channel> --classic`.

---

<div class="post-metadata">

**Author:** ![TristanStanic](https://sea2.discourse-cdn.com/flex016/user_avatar/discuss.kubernetes.io/tristanstanic/32/5148_2.png) [@TristanStanic](https://discuss.kubernetes.io/u/TristanStanic)\
**Post date:** [August 1, 2020, 2:22am UTC](https://discuss.kubernetes.io/t/microk8s-cluster-stuck-after-installing-olm-0-14-1/12094/3 "2020-08-01T02:22:26Z")

</div>

I have had RBAC enabled. I have attempted to delete the CRDs many times. Even stop/start microk8s or the rebooting the machine didn’t help.

I can of course remove and reinstall microk8s. But it would be nice to know the root cause or a way to force the deletion of CRDs. I don’t know if this kind of problem would occur often. But the solution to delete the entire cluster is quite time consuming.

---

<div class="post-metadata">

**Author:** ![balchua1](https://sea2.discourse-cdn.com/flex016/user_avatar/discuss.kubernetes.io/balchua1/32/5372_2.png) [@balchua1](https://discuss.kubernetes.io/u/balchua1)\
**Post date:** [August 1, 2020, 3:55am UTC](https://discuss.kubernetes.io/t/microk8s-cluster-stuck-after-installing-olm-0-14-1/12094/4 "2020-08-01T03:55:39Z")

</div>

I sometimes follow this article [https://www.ibm.com/support/knowledgecenter/SSBS6K\_3.2.0/troubleshoot/ns\_terminating.html](https://www.ibm.com/support/knowledgecenter/SSBS6K_3.2.0/troubleshoot/ns_terminating.html)  
It is an old one, but seems to point me to the right direction.
