# Microk8s+microceph+cephfs - Ubuntu 22

**URL:** <https://discuss.kubernetes.io/t/microk8s-microceph-cephfs-ubuntu-22/29022>\
**Category:** microk8s\
**Created:** [July 15, 2024, 4:42pm UTC](https://discuss.kubernetes.io/t/microk8s-microceph-cephfs-ubuntu-22/29022 "2024-07-15T16:42:43Z")\
**Posts on this page:** 1\
**Showing post:** 4

<div class="post-metadata">

**Author:** ![dedumose](https://sea2.discourse-cdn.com/flex016/user_avatar/discuss.kubernetes.io/dedumose/32/15612_2.png) [@dedumose](https://discuss.kubernetes.io/u/dedumose)\
**Post date:** [November 2, 2024, 12:57am UTC](https://discuss.kubernetes.io/t/microk8s-microceph-cephfs-ubuntu-22/29022/4 "2024-11-02T00:57:03Z")

</div>

@Alexander_Hermann with pleasure !

on the other hand, although with the instructions above we could see the storage class in Microk8s, however I can’t get the cluster to provision CephFS from MicroCeph, the pod that asks for the CephFS backed PVC doesn’t start, I figured it’s a storage provisioning problem after deeper investigation, apparently MicroCeph doesn’t include MDS by default:

below are the results of `ceph -s`

```auto
  cluster:
    id: 334243a2-6625-4911-8e7f-9d53ccb9670b
    health: HEALTH_ERR
            1 filesystem is offline
            1 filesystem is online with fewer MDS than max_mds
 
  services:
    mon: 3 daemons, quorum 3mk1,3mk2,3mk3 (age 39m)
    mgr: 3mk1(active, since 39m), standbys: 3mk2, 3mk3
    mds: 0/0 daemons up
    osd: 3 osds: 3 up (since 39m), 3 in (since 2d)
 
  data:
    volumes: 1/1 healthy
    pools: 6 pools, 225 pgs
    objects: 237 objects, 707 MiB
    usage: 2.0 GiB used, 298 GiB / 300 GiB avail
    pgs: 225 active+clean

```

notice that mds demons 0/0 up and mds offline

I remember I tried to start an mds service and the host machine reach 100% cpu usage and became completely non responsive.

also a bit confusing to see mds services running on all nodes from `microceph status`

```auto
microceph status
MicroCeph deployment summary:
- 3mk1 (10.128.140.59)
  Services: mds, mgr, mon, osd
  Disks: 1
- 3mk2 (10.128.140.189)
  Services: mds, mgr, mon, osd
  Disks: 1
- 3mk3 (10.128.140.120)
  Services: mds, mgr, mon, osd
  Disks: 1

```

```auto
microceph enable mds
Error: failed placing service mds: mds service unable to sustain on host: mds service is not active

```

I’ll follow up if I figured a way to make it work, also insight are welcome

---

_[View the full topic](https://discuss.kubernetes.io/t/microk8s-microceph-cephfs-ubuntu-22/29022)._
