# Node Proxy error

**URL:** <https://discuss.kubernetes.io/t/node-proxy-error/15417>\
**Category:** General Discussions\
**Created:** [April 6, 2021, 8:43am UTC](https://discuss.kubernetes.io/t/node-proxy-error/15417 "2021-04-06T08:43:32Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![lslamp](https://avatars.discourse-cdn.com/v4/letter/l/f14d63/32.png) [@lslamp](https://discuss.kubernetes.io/u/lslamp)\
**Post date:** [April 6, 2021, 8:43am UTC](https://discuss.kubernetes.io/t/node-proxy-error/15417/1 "2021-04-06T08:43:32Z")

</div>

Greetings, I am very new to Kubernetes and clustering.

### Cluster information:

I have installed the cluster on 3 x raspberry pi 4 b \*gb devices. The installation went very well. There were some hitches but I managed to eventually get it all working, and I have added a minecraft app and all is looking good.

I decided that I have a spare RSPi 3b laying around so I thought that I would try to add a node to the cluster, but this has not gone as expected.

I have tried the following ..

# Running the below command runs without errors.

AGENT\_IP=192.168.1.216  
SERVER\_IP=192.168.1.241  
k3sup join --ip $AGENT\_IP --server-ip $SERVER\_IP --user pi

# Below is the output.

Running: k3sup join  
Server IP: 192.168.1.241  
###############################################::server:#########################  
[INFO] Finding release for channel v1.19  
[INFO] Using v1.19.9+k3s1 as release  
[INFO] Skipping binary downloaded, installed k3s matches hash  
[INFO] Skipping /usr/local/bin/kubectl symlink to k3s, already exists  
[INFO] Skipping /usr/local/bin/crictl symlink to k3s, already exists  
[INFO] Skipping /usr/local/bin/ctr symlink to k3s, already exists  
[INFO] Creating killall script /usr/local/bin/k3s-killall.sh  
[INFO] Creating uninstall script /usr/local/bin/k3s-agent-uninstall.sh  
[INFO] env: Creating environment file /etc/systemd/system/k3s-agent.service.env  
[INFO] systemd: Creating service file /etc/systemd/system/k3s-agent.service  
[INFO] systemd: Enabling k3s-agent unit  
Created symlink /etc/systemd/system/multi-user.target.wants/k3s-agent.service → /etc/systemd/system/k3s-agent.service.  
[INFO] No change detected so skipping service start  
Logs: Created symlink /etc/systemd/system/multi-user.target.wants/k3s-agent.service → /etc/systemd/system/k3s-agent.service.  
Output: [INFO] Finding release for channel v1.19  
[INFO] Using v1.19.9+k3s1 as release  
[INFO] Skipping binary downloaded, installed k3s matches hash  
[INFO] Skipping /usr/local/bin/kubectl symlink to k3s, already exists  
[INFO] Skipping /usr/local/bin/crictl symlink to k3s, already exists  
[INFO] Skipping /usr/local/bin/ctr symlink to k3s, already exists  
[INFO] Creating killall script /usr/local/bin/k3s-killall.sh  
[INFO] Creating uninstall script /usr/local/bin/k3s-agent-uninstall.sh  
[INFO] env: Creating environment file /etc/systemd/system/k3s-agent.service.env  
[INFO] systemd: Creating service file /etc/systemd/system/k3s-agent.service  
[INFO] systemd: Enabling k3s-agent unit  
[INFO] No change detected so skipping service start

kubectl get node

# The results of the above command is below.

NAME STATUS ROLES AGE VERSION  
node1 Ready master 3d8h v1.19.9+k3s1  
node2 Ready worker 2d15h v1.19.9+k3s1  
node3 Ready worker 2d15h v1.19.9+k3s1

As you can see, there are 3 nodes already, I am trying to add node4

Kubernetes version:  
k3sup Version: 0.10.1

Installation method:  
Host OS: Raspberry Pi OS

What I am confused about is why the logs on the new node seem to be pointing to the wrong proxy config.  
below an extract from node4  
node4 k3s[560]: time=“2021-04-06T09:24:53.222481518+01:00” level=info msg=“Connecting to proxy” url=“wss://127.0.0.1:6443/v1-k3s/connect”

below extract from node3  
node3 k3s[576]: time=“2021-04-06T08:17:14.814518741+01:00” level=info msg=“Connecting to proxy” url=“wss://192.168.1.241:6443/v1-k3s/connect”

I don’t understand why node4 is trying to connect to a localhost when I have tried to join it to the current cluster.

Any help would be greatly appreciated.  
Thanks  
Lawrence

---

<div class="post-metadata">

**Author:** ![lslamp](https://avatars.discourse-cdn.com/v4/letter/l/f14d63/32.png) [@lslamp](https://discuss.kubernetes.io/u/lslamp)\
**Post date:** [April 6, 2021, 4:24pm UTC](https://discuss.kubernetes.io/t/node-proxy-error/15417/2 "2021-04-06T16:24:23Z")

</div>

I was browsing in the daemon.log file when I spotted something relating to a duplicate node name and something to do with password. below is an extract of the error.

Failed to retrieve agent config: Node password rejected, duplicate hostname or contents of ‘/etc/rancher/node/password’ may not match server node-passwd entry, try enabling a unique node name with the --with-node-id flag"

So I looked on node1 which is my master, I deleted the entry in the file node-passwd related to node4.  
After I deleted this entry, everything just started working. No clue how or why, but removing the line solved things.

Lawrence
