# Service "ingress-nginx-controller-admission" not found

**URL:** <https://discuss.kubernetes.io/t/service-ingress-nginx-controller-admission-not-found/13312>\
**Category:** General Discussions\
**Created:** [October 17, 2020, 4:44pm UTC](https://discuss.kubernetes.io/t/service-ingress-nginx-controller-admission-not-found/13312 "2020-10-17T16:44:35Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![rajat\_hongal](https://sea2.discourse-cdn.com/flex016/user_avatar/discuss.kubernetes.io/rajat_hongal/32/6039_2.png) [@rajat\_hongal](https://discuss.kubernetes.io/u/rajat_hongal)\
**Post date:** [October 17, 2020, 4:44pm UTC](https://discuss.kubernetes.io/t/service-ingress-nginx-controller-admission-not-found/13312/1 "2020-10-17T16:44:35Z")

</div>

Asking for help? Comment out what you need so we can get more information to help you!  
Kubernetes version: 1.16  
Cloud being used: GCP  
Installation method: helm  
Host OS: node alpine

The problem that I’m facing -  
I installed and deployed an NGINX controller on GKE but with the name my-release.  
now my services are as - my-release-ingress-nginx-controller and my-release-ingress-nginx-controller-admission

now when I apply my ingress file I get an error as below  
Error from server (InternalError): error when creating “ingress.yaml”: Internal error occurred: failed calling webhook validate .nginx.ingress.kubernetes.io :service “ingress-nginx-controller-admission” not found

once possible note that I can make here is ingress cannot read the admission file with my-release-ingress-nginx-controller-admission but instead it is looking for ingress-nginx-controller-admission.

there was no workaround to keep name as ingress-nginx-controller-admission while installing from official documentation, please do help me with this, Thank you

my ingress file -  
apiVersion: networking.k8s .io/v1beta1  
kind: Ingress  
metadata:  
name: ingress  
annotations:  
kubernetes. io/ingressClassName: nginx  
cert-manager. io/cluster-issuer: letsencrypt-prod  
nginx.ingress. kubernetes .io/use-regex: ‘true’  
nginx.ingress. kubernetes .io/rewrite-target: /  
nginx.ingress. kubernetes .io/ssl-redirect: “true”  
nginx.ingress .kubernetes .io/force-ssl-redirect: “true”  
spec:  
tls:  
- hosts:  
- [ex1.ex.com](http://ex1.ex.com)  
- [ex2.ex.com](http://ex2.ex.com)

```
      secretName: ex-tls
  rules:
    - host: ex1.ex.com
      http:
        paths:
          - backend:
              serviceName: ex1-service
              servicePort: 80
    - host: ex2.ex.com
      http:
        paths:
          - backend:
              serviceName: ex2-service
              servicePort: 80
```

---

<div class="post-metadata">

**Author:** ![alienallen](https://sea2.discourse-cdn.com/flex016/user_avatar/discuss.kubernetes.io/alienallen/32/7874_2.png) [@alienallen](https://discuss.kubernetes.io/u/alienallen)\
**Post date:** [June 10, 2021, 9:14am UTC](https://discuss.kubernetes.io/t/service-ingress-nginx-controller-admission-not-found/13312/2 "2021-06-10T09:14:02Z")

</div>

@rajat_hongal Is the problem solved? I meet a similar issue. Thanks.

---

<div class="post-metadata">

**Author:** ![rajat\_hongal](https://sea2.discourse-cdn.com/flex016/user_avatar/discuss.kubernetes.io/rajat_hongal/32/6039_2.png) [@rajat\_hongal](https://discuss.kubernetes.io/u/rajat_hongal)\
**Post date:** [June 10, 2021, 10:29am UTC](https://discuss.kubernetes.io/t/service-ingress-nginx-controller-admission-not-found/13312/3 "2021-06-10T10:29:28Z")

</div>

Hey, I was not able to resolve that issue, I flushed everything and retried with other method which I can’t remember right now, I will post the link here if I get it. you can try upgrading your cluster if you are on GCP, they now have UI implementation of ingress its is easy.
