# Setting up OIDC authentication with my EKS cluster

**URL:** <https://discuss.kubernetes.io/t/setting-up-oidc-authentication-with-my-eks-cluster/26489>\
**Category:** General Discussions\
**Tags:** network\
**Created:** [December 20, 2023, 5:02pm UTC](https://discuss.kubernetes.io/t/setting-up-oidc-authentication-with-my-eks-cluster/26489 "2023-12-20T17:02:41Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Siva\_muthu\_Kumaran](https://sea2.discourse-cdn.com/flex016/user_avatar/discuss.kubernetes.io/siva_muthu_kumaran/32/13920_2.png) [@Siva\_muthu\_Kumaran](https://discuss.kubernetes.io/u/Siva_muthu_Kumaran)\
**Post date:** [December 20, 2023, 5:02pm UTC](https://discuss.kubernetes.io/t/setting-up-oidc-authentication-with-my-eks-cluster/26489/1 "2023-12-20T17:02:41Z")

</div>

Hello everyone,

I’ve successfully set up an EKS cluster in my AWS account and configured OIDC authentication with Azure AD as the identity provider, following the instructions in this link: [link](https://aws.amazon.com/blogs/containers/using-azure-active-directory-to-authenticate-to-amazon-eks/).

However, when attempting to execute the command `kubectl --user=azure-user get nodes`, I encountered the following error:

```auto
E1220 17:01:05.101980 22361 memcache.go:265] couldn't get current server API group list: Get "<my-cluster-api-endpoint-redacted>/api?timeout=32s": getting credentials: exec: executable kubelogin failed with exit code 1
Unable to connect to the server: getting credentials: exec: executable kubelogin failed with exit code 1

```

Could you please assist me in resolving this issue?

Note: I’ve slightly modified my error message to conceal my cluster endpoint, replacing it with `<my-cluster-api-endpoint-redacted>`.

Thanks!

---

<div class="post-metadata">

**Author:** ![fox-md](https://sea2.discourse-cdn.com/flex016/user_avatar/discuss.kubernetes.io/fox-md/32/10613_2.png) [@fox-md](https://discuss.kubernetes.io/u/fox-md)\
**Post date:** [December 22, 2023, 2:16pm UTC](https://discuss.kubernetes.io/t/setting-up-oidc-authentication-with-my-eks-cluster/26489/2 "2023-12-22T14:16:40Z")

</div>

Hi,  
Worth checking kube-api logs. There must be an error logged regarding this auth attempt.
