# The connection to the server \<host\>:6443 was refused - did you specify the right host or port?

**URL:** <https://discuss.kubernetes.io/t/the-connection-to-the-server-host-6443-was-refused-did-you-specify-the-right-host-or-port/552>\
**Category:** General Discussions\
**Created:** [May 30, 2018, 12:58pm UTC](https://discuss.kubernetes.io/t/the-connection-to-the-server-host-6443-was-refused-did-you-specify-the-right-host-or-port/552 "2018-05-30T12:58:41Z")\
**Posts on this page:** 1\
**Showing post:** 83

<div class="post-metadata">

**Author:** ![sivehost](https://sea2.discourse-cdn.com/flex016/user_avatar/discuss.kubernetes.io/sivehost/32/16644_2.png) [@sivehost](https://discuss.kubernetes.io/u/sivehost)\
**Post date:** [January 7, 2025, 12:10pm UTC](https://discuss.kubernetes.io/t/the-connection-to-the-server-host-6443-was-refused-did-you-specify-the-right-host-or-port/552/83 "2025-01-07T12:10:51Z")

</div>

try sudo nano /etc/containerd/config.toml  
Then find SystemdCgroup change its value from false to true

sudo systemctl restart containerd;sudo reboot  
Check for details:

> **[Who's killing my pods? | (blog 'zezin)](https://gjhenrique.com/cgroups-k8s/)**
>
> Minimalistic Hugo blogging theme

> [@Why does etcd fail with Debian/bullseye kernel?](https://discuss.kubernetes.io/t/why-does-etcd-fail-with-debian-bullseye-kernel/19696):
>
> I while ago I tried to upgrade my system from Debian buster to Debian bulleye. But etcd stops working. So I downgraded the kernel back to the buster version, and that fixed the problem. I posted my experiences on stack overflow, which appeared to be the correct place to get support for Kubernetes, but it was closed with “We don’t allow questions about general computing hardware and software on Stack Overflow” which doesn’t make a lot of sense to me. This isn’t a general question IMHO. In hindsight maybe I should have emphasized this is a kubernetes system, that I was trying to upgrade. But no…

---

_[View the full topic](https://discuss.kubernetes.io/t/the-connection-to-the-server-host-6443-was-refused-did-you-specify-the-right-host-or-port/552)._
