About installation,network plugin,flannel

Asking for help? Comment out what you need so we can get more information to help you!

Cluster information:

Kubernetes version:1.26.1
Cloud being used: (put bare-metal if not on a public cloud) study
Installation method:kubeadm
Host OS: Centos7
CNI and version:
CRI and version:

flannel is Running
but coredns pod always Pending
kubelet log

“Container runtime network not ready” networkReady=“NetworkReady=false reason:NetworkPluginNotReady message:Network plugin returns error: cni plugin not initialized”

I tried this

kubectl delete -f https://github.com/flannel-io/flannel/releases/latest/download/kube-flannel.yml
sudo ip link del cni0
sudo ip link del flannel.1
sudo rm /etc/cni/net.d/10-flannel.conflist
kubectl apply -f https://github.com/flannel-io/flannel/releases/latest/download/kube-flannel.yml

but it dosn’t work

  • Did you do the stuff mentioned here?
  • Do the logs for flannel show any signs of problems?
  • Have you tried other CNI’s? I have used calico in the past.

no,the logs for flannel show nothing of problem, no only flannel
and i reboot the centos,it’s worked :joy: