Autopilot cluster not responding

Cluster information:

$ kubectl version

Client Version: version.Info{Major:“1”, Minor:“21”, GitVersion:“v1.21.1”, GitCommit:“5e58841cce77d4bc13713ad2b91fa0d961e69192”, GitTreeState:“clean”, BuildDate:“2021-05-12T14:18:45Z”, GoVersion:“go1.16.4”, Compiler:“gc”, Platform:“linux/amd64”}
Unable to connect to the server: context deadline exceeded

I’ve recently created an autopilot cluster and after adding a few deployments it stopped responding. I can’t even do:

kubectl get pods

it times out with the error

Unable to connect to the server: dial tcp 172.16.xx.xx:443: i/o timeout

so I tried:

gcloud container clusters get-credentials autopilot-cluster-1 --region us-west2 --project site-staging-xxxx

and I get:

Fetching cluster endpoint and auth data.

WARNING: cluster autopilot-cluster-1 is not running. The kubernetes API may not be available.

kubeconfig entry generated for autopilot-cluster-1.

I’m at a loss… I’ve googled till I’m blue in the face but can’t find how to restart it. all help much appreciated

Hi @ekkis . Haven’t come across that one yet but I am curious as to what the cluster state is being reported as in the GKE console?


How long has the issue persisted?

It’s possible the API was temporarily unavailable due to upgrading. It’s also possible failing due to a billing issue.

I would suggest testing it again and, if it’s still not working, trying to create / delete a new autopilot cluster to ensure general function works.

it was a billing issue. it needed some kind of upgrade to my account but the message informing me of that didn’t show up till this morning. everything seems to be working now