Centos8 systemd failed to connect to bus

When i run my pod with Centos7 systemd run correctly but if i run the pod with centos8 systemd not load the bus.
I don’understand I use th same commande to build the image.

Is it simlar to the error reported here?

It isn t rois error. Tank. systemd not connect to thé bus. But this image run with docker with privilège. If i run image insid kubernetes sysemd faild. For kubernetes i use to privilège.
Thé same command run i process with thé same image but in version centos7

Sorry i didn’t get the issue you are experiencing.
Let me try to clarify one thing.
Are you trying to run a container with systemd inside?
Your image is using centos8 or your host server where MicroK8s is installed is running Centos8?

I whould like run a pod with Centos8 and systemd service. But it doesn’t connect to the bus (systemd failed to connect to bus no such file or directory).
But the image run if this run by docker.
Prevouisly I ran the same with centos7 (Docker image, and kubernetes pod), the pod run correctly systemd service.

The event is when I use centos8. But I set the image with the same parameters?
RUN (cd /lib/systemd/system/sysinit.target.wants/; for i in ; do [ $i == systemd-tmpfiles-setup.service ] || rm -f $i; done);
rm -f /lib/systemd/system/multi-user.target.wants/
rm -f /etc/systemd/system/.wants/;
rm -f /lib/systemd/system/local-fs.target.wants/;
rm -f /lib/systemd/system/sockets.target.wants/udev;
rm -f /lib/systemd/system/sockets.target.wants/initctl;
rm -f /lib/systemd/system/basic.target.wants/
rm -f /lib/systemd/system/anaconda.target.wants/*;
VOLUME [ “/sys/fs/cgroup” ]
CMD ["/usr/sbin/init"]

Hi do you have a github repo that i can see to help reproduce and troubleshoot the error?