ContainerCreating but never ready

Cluster information:

Kubernetes version:
Cloud being used: AWS EC2 T3a-small
Installation method: sudo yum -y install
Host OS: Amazon Linux 2
CNI and version: Unknown - Unknown
CRI and version: systemd - Unknown

I am new to kubernetes and have a home brewed Kubernetes cluster on an amazon EC2.

cat <<EOF | sudo tee /etc/yum.repos.d/kubernetes.repo 
exclude=kubelet kubeadm kubectl 

sudo yum -y install docker iproute-tc kubelet kubectl kubeadm --disableexcludes=kubernetes

net.bridge.bridge-nf-call-iptables = 1

ExecStart=/usr/bin/dockerd -H fd:// --containerd=/run/containerd/containerd.sock $OPTIONS $DOCKER_STORAGE_OPTIONS $DOCKER_ADD_RUNTIMES --exec-opt native.cgroupdriver=systemd

Then docker, containerd, and kubelet were all enabled and started.

Ran sudo kubeadm init

At this stage the node is not ready.

Next I ran:

kubectl apply -f
kubectl apply -f

Flannel here may be a red herring but it seemed to make progress. The node now shows ready.

I created a deployment.yaml file based on this: Run a Stateless Application Using a Deployment | Kubernetes

kubectl apply -f deployment.yaml

Tried Weave in a vein hope:

kubectl apply -f "$(kubectl version | base64 | tr -d '\n')"

Allow pods to schedule on the master node: kubectl taint nodes --all

The pod shows as ContainerCreating. So I guess this is where it gets interesting as we now enter the realm of the logs.

kubectl get events --all-namespaces --sort-by='.metadata.creationTimestamp'

Too much to paste here but lots of lines looking like Warning FailedCreatePodSandBox

The command docker ps reports that all containers are paused.

journalctl -u kubelet

The first error shows:

server.go:198] failed to load Kubelet config file /var/lib/kubelet/config.yaml, error failed to read kubelet config file "/var/lib/kubelet/config.yaml", error: open /var/lib/kubelet/config.yaml: no such file or directory

ls -alh shows the file exists and is 876B.

There is probably more than one thing going on here. Would you please point me to helpful documentation and explain how to resolve this?

Thank you.