Defining node ip address

Hi there. As far as support request issue link from github leads here, I’ll post my question in a topic. And will appreciate if someone is able to help.
I have a two node cluster. Each node has two network interfaces - eth0 with public IP assigned and eth1 with private IP. After cluster initialization all nodes has their public addresses as INTERNAL-IP

$ k get nodes -o wide
do-k8s-01   Ready    control-plane   3h15m   v1.26.2   209.XX.XX.XX   <none>        Debian GNU/Linux 11 (bullseye)   5.10.0-23-amd64   containerd://1.7.1
do-k8s-02   Ready    <none>          98m     v1.26.2   68.XX.XX.XX   <none>        Debian GNU/Linux 11 (bullseye)   5.10.0-23-amd64   containerd://1.7.1

Cluster is deployed via kubeadm tool. I would like to use private ip adress assigned to eth1 interace as nodeIP, but can’t set it.
I have read in documentation about --node-ip parameter for kubelet. But seams it doesn’t work. I have tried to add nodeIP: to my kubelet yaml config file, but after its restart nodeIP hasn’t been changed. I have also tried to add --node-ip= to kubelet.service file, but also with no luck.
I would be appreciate if someone can show me a sample of kubelet config where node address will be defined properly.

Cluster information:

Kubernetes version: 1.26
Cloud being used: self managed cluster on Digital Ocean
Installation method: kubeadm
Host OS: debian 11
CNI and version: cni-plugins-linux-amd64-v1.3.0
CRI and version: containerd://1.7.1

You can format your yaml by highlighting it and pressing Ctrl-Shift-C, it will make your output easier to read.

What worked for me were the following steps. Let’s say we want to assign IP address to the node

  1. Edit /etc/hosts and add “
  2. Edit /var/lib/kubelet/kubeadm-flags.env and add “–node-ip=”
  3. (re) join the cluster