E: The repository 'https://apt.kubernetes.io kubernetes-xenial Release' does not have a Release file

Hello everyone, I’d like to ask about an error I’ve encountered recently.

I tried several times to install Kubernetes and experienced an error when running the following command “echo “deb [signed-by=/etc/apt/keyrings/kubernetes-archive-keyring.gpg] https://apt.kubernetes.io/kubernetes- xenial main” | sudo tee /etc/apt/sources.list.d/kubernetes.list”. and until now I don’t know how to solve this problem, maybe someone can help me solve it. Thank you, waiting for the answer, friends

I solved this problem with
echo “deb [signed-by=/etc/apt/keyrings/kubernetes-apt-keyring.gpg] https://pkgs.k8s.io/core:/stable:/v1.28/deb/ /” | sudo tee /etc/apt/sources.list.d/kubernetes.list
curl -fsSL https://pkgs.k8s.io/core:/stable:/v1.28/deb/Release.key | sudo gpg --dearmor -o /etc/apt/keyrings/kubernetes-apt-keyring.gpg
sudo apt-get update
from there
pkgs.k8s.io: Introducing Kubernetes Community-Owned Package Repositories | Kubernetes