Gitlab, Helm and Proxy


#1

Hello,

When I try to install Helm Tiller on my Kubernetes Cluster with Gitlab UI, I get the following error :

Something went wrong while installing Helm Tiller

    Installation failed. Check pod logs for install-helm for more details.

Then, when I check the pod logs, I see the following output :

 + helm init --tiller-tls --tiller-tls-verify --tls-ca-cert /data/helm/helm/config/ca.pem --tiller-tls-cert /data/helm/helm/config/cert.pem --tiller-tls-key /data/helm/helm/config/key.pem
Creating /root/.helm 
Creating /root/.helm/repository 
Creating /root/.helm/repository/cache 
Creating /root/.helm/repository/local 
Creating /root/.helm/plugins 
Creating /root/.helm/starters 
Creating /root/.helm/cache/archive 
Creating /root/.helm/repository/repositories.yaml 
Adding stable repo with URL: https://kubernetes-charts.storage.googleapis.com 
Error: Looks like "https://kubernetes-charts.storage.googleapis.com" is not a valid chart repository or cannot be reached: Get https://kubernetes-charts.storage.googleapis.com/index.yaml: dial tcp 172.217.22.144:443: connect: connection timed out 

I can still try to install it manually, but the problem is I’m not sure that Gitlab-CI will recognize it and allow me to install the rest of the applications with its UI.

After checking, the container image used in this pod is the following :
registry.gitlab.com/gitlab-org/cluster-integration/helm-install-image/releases/2.11.0-kube-1.11.0

The node where the problem happened is a CentOs, version : 7.5.1804.

Do you have any idea of how I can fix this ? I tried several times and I still get the error.
We do have a proxy, but the cluster is supposed to be well configured. I tried to curl “https://kubernetes-charts.storage.googleapis.com/index.yaml” from every node and there was no problem. Maybe the container needs to have the same proxy configuration. The problem is that the pod is deployed by Gitlab, so I can’t write my own deployment config with the proxy variables.


#2

I figured out the problem, it is the Gitlab container launched by the GUI which doesn’t give the possibility to set the HTTP_PROXY environment variable. That’s why it cannot reach the URL.