How to set cpuManagerPolicyOptions align-by-socket or full-pcpus-only?

Cluster information:

Kubernetes version: v1.25.0
Cloud being used: bare-metal
Installation method: helm
Host OS: Ubuntu 22.04
CNI and version: Flannel
CRI and version: containerd://1.6.6

how do we set the cpuManagerPolicyOptions for align-by-socket or full-pcpus-only?

Currently this is what I have implemented on the node that I would like this to take effect on:


  cpu: "1"
  memory: "2Gi"
  cpu: "1"
  memory: "2Gi"
cpuManagerPolicy: "static"
  align-by-socket: "true"
  CPUManager: true
  CPUManagerPolicyOptions: true
  CPUManagerPolicyAlphaOptions: true
  CPUManagerPolicyBetaOptions: true

From the documentation static-policy-options, it states that I need to enable CPUManagerPolicyAlphaOptions which I did as seen in the config above.

After that I ran:

sudo rm -rf /var/lib/kubelet/cpu_manager_state
sudo systemctl daemon-reload
sudo systemctl stop kubelet
sudo systemctl start kubelet

But I noticed my pods are still not aligning based on the socket (I have 2 CPU sockets). Is there anything that I am missing?

I tried with full-pcpus-only and same results as well.