Init failing due to kube-proxy service account

Cluster information:

Kubernetes version: Major 1 Minor 25
Cloud being used: bare-metal
Installation method: HA 3 Master + 3 Worker
Host OS: Redhat Enterprise Linux
CNI and version: Calico or Flannel, havent made it that far yet
CRI and version: Docker 20.10.9

So i’ve tried setting up a HA cluster on RHEL however when running init i get the below error.

I followed this article to install and configure keepalived and installed ha-proxy via snapd with the command sudo snap install kube-proxy --classic which worked.

Then i tried initializing the cluster with kubeadm init --control-plane-endpoint "{vip from keepalived}:6443" --upload-certs --pod-network-cidr

If i skip the addon/ha-proxy part of the setup the cluster creates successfully however the networking all fails to setup properly, i would assume because coreDNS seems to depend on it. I’ve tried allowing the ports through firewalld and even turning firewalld off altogether but get the exact same errors.

I also havent found any good guides on setting up a highly available kubernetes cluster on Redhat. Is anyone able to link one or help with debugging my current issues?