Kubernetes Cluster | Unable to launch the application using Master Node

#1

Cluster information:

Kubernetes version: v1.14
Cloud being used: (put bare-metal if not on a public cloud) Microsoft Azure
Installation method: kubeadm
Host OS: Linux-Ubuntu
CNI and version: Calico
CRI and version: Docker

Problem Statement:

I have two Virtual Machines (Linux-Ubuntu) on Microsoft Azure one as a master node and other as a worker node. In my kubernetes cluster I have deployed a Nginx server which has been assigned to worker Node.

The problem is I am able to access the Nginx server on worker node ip i.e using command: curl ip_address_of_Nginx_pod but when I try to run the same command on Master Node its not working.

There is some issue with Inbound Rules I think. However I have already allowed all traffic on both master and worker node.

On Master Node:

Once I run Command : kubectl get pods

NAME         READY   STATUS    RESTARTS   AGE   IP            NODE              
myfirstpod   1/1     Running   1          23h   192.168.2.10   demo-my-worker 

Once I run Command : curl 192.168.2.10 , It does not display anything…

root@Demo-my-master:~/demo# curl 192.168.2.10

On Worker Node:

Once I run Command : curl 192.168.2.10, it runs perfectly fine.

root@Demo-my-worker:~/demo# curl 192.168.2.10


<head>
<title>Welcome to nginx!</title>
<style>
body {
    width: 35em;
    margin: 0 auto;
    font-family: Tahoma, Verdana, Arial, sans-serif;
}
</style>
</head>
<body>
<h1>Welcome to nginx!</h1>
<p>If you see this page, the nginx web server is successfully installed 
and
working. Further configuration is required.</p>

<p>For online documentation and support please refer to
<a href="http://nginx.org/">nginx.org</a>.<br/>
Commercial support is available at
<a href="http://nginx.com/">nginx.com</a>.</p>

<p><em>Thank you for using nginx.</em></p>
</body>
</html>

Can please someone help here and let me know why I am not able to get the same result on master node ?