Kubernetes pod cannot access service which is running on another node

Cluster information:

Kubernetes version: 1.20
Installation method: Kubeadm
Host OS: Debian 10.9
CNI and version: Calico v3
CRI and version: Docker v18

Hello all,
I have a Kubernetes cluster with 1 master and 2 nodes all of them Debian 10.9, I used Kubeadm and Calico. I’ve applications deployed in node1 and node2.
the issue is: any pod hosted in node1 is inaccessible from other pods nor services in the cluster,
for example, I’ve nginx1 pod in node1 and exposed with a clusterIP service
I’ve nginx2 pod in node2, I tried to reach and ping nginx1 from nginx2 but not working, any other pods in node1 have the same issue, pods in node2 have no issue,
the DNS name is resolved, but there is not access even throw IP of the service/pod
I checked the logs of kube-proxy it didn’t show any errors
NodePort is working fine but ClusterIP is not working in my case
I appreciate it if you can help me solving this issue

Did you expose the point in the container portion of the pod spec?

Are you using a service? If so are the selectors right? Can you access it with kubectl port-forward?

How are you trying to connect from pod to pod? Via DNS or IP?

Are there any existing network policies in place?

the same container I deploy it in node2 and works fine it’s not about the pod definition or the container
I tried the port forward it works fine
I tried to connect using DNS and IP both of them not working
but the DNS name is resolved

Have you read through the system requirements for Calico?

When I was reading this, something really stuck out to me:

The IP range selected for pod IP addresses cannot overlap
with any other IP ranges in your network, including:

    The Kubernetes service cluster IP range
    The range from which host IPs are allocated

Do you have any pods communicating between nodes?

What are the configured subnets that you’re using for your cluster?

do you suggest to replace calico with weave-net or any alternative CNI? @protosam