New in kubernetes ingress-nginx


#1

I’m new in kubernetes. We are using Docker-EE with the kubernetes orchestration as default. I have deployed, via kubectl commands a deployment/service and ingress. After that I have one pod and the nginx configuration has been automatically updated. Nice so far…

Now the application deployed requires request headers set by some component before the request goes to the kubernetes environment. When request is made, the request is proxied to the correct pod, BUT I don’t see the original headers coming in, all seems the ones set by the ingress-nginx.

This is the procedurs I used to configure the ingress-nginx, https://docs.docker.com/ee/ucp/kubernetes/layer-7-routing/

I found this option

Syntax: proxy_pass_request_headers on off ;
Default: proxy_pass_request_headers on;
Context: http , server , location

The value on seems to be the default but that’s not what I see. I can’t find neither some referecne setting this option off, so expecting the option to be on, by default.

Please advise…
Walter