Path to microk8s docker registry sock?

I had a development ubuntu 18.04 and installed microk8s v1.18.2.

I had a docker client in my Eclipse IDE and I would like to connect it to the microk8s’ docker registry daemon but I can’t find its sock address.
Some colleague told me that it used to be: unix:///var/snap/microk8s/docker.sock, but I haven’t this on my environment.

could someone point me to the right path ?

Not at a computer right now but have you tried checking the command line of microk8s to see if it’s specified?

Maybe something like:

ps -ef | grep microk8s

Or maybe grep for kubelet.

Kind regards,

Hi Stephen, I did it now and I also tried to grep for kubelet or .sock, but I couldn’t find anything.

I installed it just now on Ubuntu 19.10 and noticed that microk8s uses containerd:

root      33330      1  1 12:14 ?        00:00:01 /snap/microk8s/1378/kubelet --kubeconfig=/var/snap/microk8s/1378/credentials/kubelet.config --cert-dir=/var/snap/microk8s/1378/certs --client-ca-file=/var/snap/microk8s/1378/certs/ca.crt --anonymous-auth=false --network-plugin=cni --root-dir=/var/snap/microk8s/common/var/lib/kubelet --fail-swap-on=false --cni-conf-dir=/var/snap/microk8s/1378/args/cni-network/ --cni-bin-dir=/snap/microk8s/1378/opt/cni/bin/ --feature-gates=DevicePlugins=true --eviction-hard=memory.available<100Mi,nodefs.available<1Gi,imagefs.available<1Gi --container-runtime=remote --container-runtime-endpoint=/var/snap/microk8s/common/run/containerd.sock --containerd=/var/snap/microk8s/common/run/containerd.sock --runtime-cgroups=/systemd/system.slice --kubelet-cgroups=/systemd/system.slice

Not sure if it’s the same on 18.04 but if it is then I am not exactly sure if you can access the containerd “stuff” using Docker.
Does Eclipse support interfacing directly with containerd?

Kind regards,

I don’t know about containerd, yet.
I think Eclipse Docker plugin can’t interact with containerd yet. I tried to pass the containerd’s sock but it returned an error.

I need to investigate how can this new containerd be accessed.