Recommended etcd minimum versions: 3.1.11+, 3.2.10+, 3.3.0+


#1

Fwd’d from etcd-dev via Joe Betz

If you run etcd in production, please read!

A couple recent issue report on github for both etcd and Kubernetes github have highlighted the fact that some older versions of etcd contain defects severe enough that we should avoid running them in production, including a data corruption bug. Also, with Kubernetes deprecating etcd 2.x support this year and the officially maintained etcd versions being 3.1+,

The minimum recommended versions of etcd to run in production are:

3.1.11+

3.2.10+

3.3.0+

-Joe


Kubernetes Weekly Community Meeting
pinned #2