Running kubelet or not running

I run kubeadm such as:
root@debian:~# kubeadm init --apiserver-advertise-address=192.168.0.120 --pod-network-cidr=192.168.0.0/24 W0904 09:36:58.767258 6500 version.go:104] could not fetch a Kubernetes version from the internet: unable to fetch file. URL: "https://dl.k8s.io/release/stable-1.txt", status: 403 Forbidden W0904 09:36:58.767492 6500 version.go:105] falling back to the local client version: v1.25.0 [init] Using Kubernetes version: v1.25.0 [preflight] Running pre-flight checks [WARNING SystemVerification]: missing optional cgroups: blkio error execution phase preflight: [preflight] Some fatal errors occurred: [ERROR Port-10257]: Port 10257 is in use [ERROR Port-10250]: Port 10250 is in use [preflight] If you know what you are doing, you can make a check non-fatal with –ignore-preflight-errors=… To see the stack trace of this error execute with --v=5 or higher

It tell me kubelet is running, Then I stop kubelet But I get the following error when I run kubeadm:


[kubelet-check] Initial timeout of 40s passed.
Unfortunately, an error has occurred:
	timed out waiting for the condition

This error is likely caused by:
	- The kubelet is not running
	- The kubelet is unhealthy due to a misconfiguration of the node in some way (required cgroups disabled)

If you are on a systemd-powered system, you can try to troubleshoot the error with the following commands:
	- 'systemctl status kubelet'
	- 'journalctl -xeu kubelet'

Additionally, a control plane component may have crashed or exited when started by the container runtime.
To troubleshoot, list all containers using your preferred container runtimes CLI.
Here is one example how you may list all running Kubernetes containers by using crictl:
	- 'crictl --runtime-endpoint unix:///var/run/containerd/containerd.sock ps -a | grep kube | grep -v pause'
	Once you have found the failing container, you can inspect its logs with:
	- 'crictl --runtime-endpoint unix:///var/run/containerd/containerd.sock logs CONTAINERID'
error execution phase wait-control-plane: couldn't initialize a Kubernetes cluster

How can I run kubelet + kubeadm?

At first you have to reset such as:

kubeadm reset

Then use a permanent IP and then run kubeadm init