Using swap & k8s (kubeadm) on a single node, no scaling


I’m using k8s (kubeadm) as a single-node master.
by design, I have no intention to scale up by adding more nodes.

I was required to disable swap during kubeadm init. This made me wondering, in my use-case,
can I re-enable swap and make k8s use it?
I could really utilize the extra virtual-memory in high-load scenarios