30s delay in kubectl rollout status statefulset command

Approx. 30s delay for kubectl rollout command to get executed with --kubeconfig=<kubeconfig_path>.

The same command works very fast without kubeconfig file.

Can anyone suggest how to resolve this issue or any tweaks that can be done to reduce the delay.

Also please let me know if the delay is default set to 30s and cannot be changes.

Are the config files on different partitions or does one rely on some provider utils? The cause for this is unlikely due to using --kubeconfig, but instead due to the config you are supplying needing to do something more.

Try running them both with verbose flags to figure out what’s happening.

 % kubectl options
    -v, --v=0:
	number for the log level verbosity