APiVersion- v1- error

Hi,
I have a question:
this it my yaml:

apiVersion: v1
kind: Namespace
metadata:
  name:  somename

and I got this:

(inner-domain-328310)$ kubectl apply -f .
W0612 11:52:56.368885 624 gcp.go:120] WARNING: the gcp auth plugin is deprecated in v1.22+, unavailable in v1.25+; use gcloud instead.
To learn more, consult Kubectl auth changes in GKE v1.25 : gke-gcloud-auth-plugin | Google Cloud Blog
error validating “somename.yaml”: error validating data: apiVersion not set; if you choose to ignore these errors, turn validation off with --validate=false
error validating “sd.yaml”: error validating data: apiVersion not set; if you choose to ignore these errors, turn validation off with --validate=false

someone knows what the problem is?
thanks