Config file not taking apiserveradvertiseaddress in version 1.13.1


#1

apiVersion: kubeadm.k8s.io/v1beta1
kind: ClusterConfiguration
kubernetesVersion: v1.13.1
apiServer:
extraArgs:
apiserver-advertise-address: “192.168.56.101”
feature-gates: SCTPSupport=true
pod-network-cidr: 192.168.0.0/16

apiserver-advertise address is not taken by kubernetes.


#2

It should just be advertise-address.
Check the example configuration under the Customizing control plane configuration with kubeadm docs or take a look at the example config below:

apiVersion: kubeadm.k8s.io/v1beta1
kind: ClusterConfiguration
kubernetesVersion: v1.13.0
metadata:
  name: 1.13-sample
apiServer:
  extraArgs:
    advertise-address: 192.168.0.103
    anonymous-auth: false
    enable-admission-plugins: AlwaysPullImages,DefaultStorageClass
    audit-log-path: /home/johndoe/audit.log

#3

thanks, i used localAPIEndpoint for the same