Dashboard will not load on 5 node Ubuntu Cluster

This is the OUTPUT of my Deployment command:

vanimal@k8fs01:~$ microk8s kubectl get deployment -A
kube-system metrics-server 1/1 1 1 174m
kube-system dashboard-metrics-scraper 1/1 1 1 174m
kube-system kubernetes-dashboard 1/1 1 1 174m
kube-system coredns 1/1 1 1 43m
kube-system calico-kube-controllers 0/1 1 0 30h

I ran the following command to get my proxy going:

microk8s.kubectl proxy --accept-hosts=. --address= &*

If I open my browser and add the following URL - I get to the Kubernetes Dashboard - Blue screen asking me for a Token or a config file

I use the following string to get my token:

token=$(microk8s kubectl -n kube-system get secret | grep default-token | cut -d " " -f1)

When I add my token in and click “Sign In” it simply sits there. I have tried removing the last few characters of the token just to be sure it was actually seeing the token, when I do that I get the following error:

Unauthorized (401): Invalid credentials provided

So I know the token is actually being read and validated - but still - it will not move when I click “Sign In” - I have rebooted the 1st Node a couple times just to be sure nothing was off, and restarted the proxy - same result

What am I missing here?