GCP Cloud Config - How to configure cloud provider and config for the manually deployed K8S cluster in GCP cloud



Please provide a steps for integrating GCP cloud for configuring the GLB and Storage for my Kubernetes cluster, which is manually deployed in GCP cloud.


There are tons of documentation for that. What have you tried and didn’t work and with which error? That way it would be more easy to help :slight_smile:


Hi Rata, Thanks for the reply, actually I referred some documentation and tried to configure the GCP disks to my K8S cluster but I am keep getting this error repeatedly,

Name: web-storage
Namespace: default
StorageClass: slow
Status: Pending
Annotations: volume.beta.kubernetes.io/storage-class=slow
Finalizers: [kubernetes.io/pvc-protection]
Access Modes:

The disk PVC not getting created and showing pending only, So I need a proper document to configure the cloud, Storage and LB etc.

Recently I referred this link https://github.com/kubernetes/kubernetes/issues/66564, still no luck.


I agree with @rata here. There are tons of guides and documentation for these things, and we don’t have enough to go on if you don’t provide more details than that your cluster is “manually deployed”.

I would suggest that you use a tool that is made for setting up clusters and not have to deal with the worst annoyances. So go with e.g. kubespray or (even friendlier!) kops and get this lower-level stuff out of the way so you can focus on solving more interesting problems. :slight_smile:


Not sure I follow. A proper document to configure your installation? Are you doing it manually or with some other tool?



Actually I followed “https://github.com/kelseyhightower/kubernetes-the-hard-way” to deploy the kubernetes cluster because I need a systemd kubernetes services don’t want the kube services running as containers, I already done for KOPS and KubeADM, now I am facing this cloud config issues in the manual installation

My Cloud Config details are,

project-id = <project-id>
network-name = <network-name>
node-tags = <node-tags>
node-instance-prefix = <instance-prefix>
multizone = true

I provided all the details and configured the service account for the cloud, still getting the same error