How to work with a private registry

Often organisations have their own private registry to assist collaboration and accelerate development. Kubernetes (and thus MicroK8s) need to be aware of the registry endpoints before being able to pull container images.

Insecure registry

Pushing from Docker

Let’s assume the private insecure registry is at 10.141.241.175 on port 32000. The images we build need to be tagged with the registry endpoint:

docker build . -t 10.141.241.175:32000/mynginx:registry

Pushing the mynginx image at this point will fail because the local Docker does not trust the private insecure registry. The docker daemon used for building images should be configured to trust the private insecure registry. This is done by marking the registry endpoint in /etc/docker/daemon.json:

{
  "insecure-registries" : ["10.141.241.175:32000"]
}

Restart the Docker daemon on the host to load the new configuration:

sudo systemctl restart docker

Now running

docker push  10.141.241.175:32000/mynginx

…should succeed in uploading the image to the registry.

Configuring MicroK8s

Attempting to pull an image in MicroK8s at this point will result in an error like this:

  Warning  Failed             1s (x2 over 16s)  kubelet, jackal-vgn-fz11m  Failed to pull image "10.141.241.175:32000/mynginx:registry": rpc error: code = Unknown desc = failed to resolve image "10.141.241.175:32000/mynginx:registry": no available registry endpoint: failed to do request: Head https://10.141.241.175:32000/v2/mynginx/manifests/registry: http: server gave HTTP response to HTTPS client

For MicroK8s version 1.23 or newer

MicroK8s 1.23 and newer versions use separate hosts.toml files for each image registry. For registry http://10.141.241.175:32000, this would be at /var/snap/microk8s/current/args/certs.d/10.141.241.175:32000/hosts.toml. First, create the directory if it does not exist:

sudo mkdir -p /var/snap/microk8s/current/args/certs.d/10.141.241.175:32000
sudo touch /var/snap/microk8s/current/args/certs.d/10.141.241.175:32000/hosts.toml

Then, edit the file we just created and make sure the contents are as follows:

# /var/snap/microk8s/current/args/certs.d/10.141.241.175:32000/hosts.toml
server = "http://10.141.241.175:32000"

[host."10.141.241.175:32000"]
capabilities = ["pull", "resolve"]

Restart MicroK8s to have the new configuration loaded:

microk8s stop
microk8s start

For MicroK8s version 1.22 or older

We need to edit /var/snap/microk8s/current/args/containerd-template.toml and add the following under [plugins."io.containerd.grpc.v1.cri".registry.mirrors]:

[plugins."io.containerd.grpc.v1.cri".registry.mirrors."10.141.241.175:32000"]
endpoint = ["http://10.141.241.175:32000"]

See the full file here.

Restart MicroK8s to have the new configuration loaded:

microk8s stop
microk8s start

The image can now be deployed with:

microk8s kubectl create deployment nginx --image=10.141.241.175:32000/mynginx:registry

Note that the image is referenced with 10.141.241.175:32000/mynginx:registry.

Secure registry

There are a lot of ways to setup a private secure registry that may slightly change the way you interact with it. Instead of diving into the specifics of each setup we provide here two pointers on how you can approach the integration with Kubernetes.

  • In the official Kubernetes documentation a method is described for creating a secret from the Docker login credentials and using this to access the secure registry. To achieve this, imagePullSecrets is used as part of the container spec.

  • MicroK8s v1.14 and onwards uses containerd. As described here, users should be aware of the secure registry and the credentials needed to access it.

    It is possible to configure default credentials in the configuration of containerd, so that they are used automatically when pulling images from your private registry, without users having to specify an image pull secret manually for each container.

    To do this, you have to edit /var/snap/microk8s/current/args/containerd-template.toml. If the private registry at 10.141.241.175:32000 needs authentication with username my-secret-user and password my-safe-password, add the following section (the configuration is in TOML format, so indentation does not matter):

    # containerd-template.toml
    
    [plugins."io.containerd.grpc.v1.cri".registry.configs."10.141.241.175:32000".auth]
    username = "my-secret-user"
    password = "my-safe-password"
    
1 Like

I am not following " Secure registry" section.

  • first bullet says official kubernetes does it this way.
    • How does this relate to microk8s’ kubernetes approach?
    • Can I follow instructions for any kubernetes when using microk8s? I tried and it did not work.
  • second bullet says internally microk8 uses containerd. Not sure how microk8s uses containerd.
    • how does dockerhub.com relate to the label plugin.“io.containerd.grpc.v1.cri”.registry.configs.“gcr.io”.auth?

I want to use public and private images stored in dockerhub. Is this a common use case?
If so, what do I need to configure in microk8s?

Hi @John_Grabner

In /var/snap/microk8s/current/args/containerd-template.toml you will have to add the registry you want to use. Have a look at [1] on entering the registry credentials. You would also want to microk8s.stop; microk8s.start after editing the containerd-template.toml file.

[1] https://github.com/containerd/cri/blob/master/docs/registry.md#configure-registry-credentials

This solution doesn’t work for me. I think this might be caused by disabled “cri” plugin in /etc/containerd/

even after added this additional config options

[plugin.“io.containerd.grpc.v1.cri”.registry.configs]
[plugin.“io.containerd.grpc.v1.cri”.registry.configs.“custom.registry.com:8091”.auth]
auth = “…”

I’ve solved the problem - this configuration has a bug - there should be:
[plugins.“io.containerd.grpc.v1.cri”.registry.configs]

The syntax for containerd config changed after 1.3 but yes, it should now be plugins. i don’t think the containerd doc is particularly clear on this.

Should be available to bootstrap a node doing this ? My vm does not have access to docker or gcr.io everything is through a nexus. But so far i have fail to bootstrap the node

[plugins."io.containerd.grpc.v1.cri".registry.mirrors]
  [plugins."io.containerd.grpc.v1.cri".registry.mirrors."docker.io"]
    endpoint = ["https://nexus.hub.cu", ]
  [plugins."io.containerd.grpc.v1.cri".registry.mirrors."gcr.io"]
    endpoint = ["https://nexus.hub.cu", ]

I don’t think you need the https. Also I think you need a config section. I’ll follow up with an example later when I am at a computer.

Thank you, looking forward to it.

Looks like the https might be necessary. The 2nd part to this is to set insecure_skip_verify though. It’s in this section of the containerd github.

[plugins."io.containerd.grpc.v1.cri".registry.mirrors."registry.somesite.tld"]
    endpoint = ["http://registry.somesite.tld"]
[plugins."io.containerd.grpc.v1.cri".registry.configs."registry.somesite.tld".tls]
  insecure_skip_verify = true

No luck, this is how it look.

[plugins."io.containerd.grpc.v1.cri".registry.mirrors]
  [plugins."io.containerd.grpc.v1.cri".registry.mirrors."docker.io"]
    endpoint = ["https://nexus.hub.cu", ]
  [plugins."io.containerd.grpc.v1.cri".registry.configs]
    [plugins."io.containerd.grpc.v1.cri".registry.configs."docker.io".tls]
      insecure_skip_verify = true
  [plugins."io.containerd.grpc.v1.cri".registry.mirrors."gcr.io"]
    endpoint = ["https://nexus.hub.cu", ]
  [plugins."io.containerd.grpc.v1.cri".registry.configs]
    [plugins."io.containerd.grpc.v1.cri".registry.configs."gcr.io".tls]
      insecure_skip_verify = true

sorry @protosam there is a limit of reply:
to your question:
`nope, gcr.io and docker.io are both only reachable through the nexus.

Currently on my phone. Though I think gcr.io != nexus.hub.cu?

I think you probably need something like this.

[plugins."io.containerd.grpc.v1.cri".registry.mirrors]
  [plugins."io.containerd.grpc.v1.cri".registry.mirrors."nexus.hub.cu"]
    endpoint = ["https://nexus.hub.cu", ]
  [plugins."io.containerd.grpc.v1.cri".registry.configs]
    [plugins."io.containerd.grpc.v1.cri".registry.configs."nexus.hub.cu".tls]
      insecure_skip_verify = true