Kubeadmin join throws this error "/proc/sys/net/bridge/bridge-nf-call-iptables does not exist"

Dear All,
I was able to setup one master and 2 nodes joined to my setup earlier, after few days when I am trying to connect to the nodes

itsupport@k8s-master:~$ kubectl get nodes

NAME         STATUS   ROLES           AGE   VERSION
k8s-master   Ready    control-plane   8d    v1.27.3
k8s-node-a   Ready    <none>          8d    v1.27.3
k8s-node-b   Ready    <none>          8d    v1.27.3
itsupport@k8s-master:~$

Today I followed the same procedure on a fresh installed ubuntu instance and did the kubectl join command, it is throwing this error

**sudo kubeadm join X.X.X.X:6443 --token **

[preflight] Running pre-flight checks
error execution phase preflight: [preflight] Some fatal errors occurred:
        [ERROR FileContent--proc-sys-net-bridge-bridge-nf-call-iptables]: /proc/sys/net/bridge/bridge-nf-call-iptables does not exist
[preflight] If you know what you are doing, you can make a check non-fatal with `--ignore-preflight-errors=...`
To see the stack trace of this error execute with --v=5 or higher

when I checked the directory for /proc/sys/net/bridge
In the path I am not seeing the directory “bridge” in “/proc/sys/net/”

Request members to advice me with the links where I could check and trouble shoot the same and find the reason why the bridge directory and corresponding files is missing
Thanks
Joseph John

Cluster information:

Client Version: v1.27.3
Kustomize Version: v5.0.1
Server Version: v1.27.3
Cloud being used: bare metal
Installation method: deb
Host OS: Ubuntu 22.04
CNI and version:
CRI and version:

fix it by:

modprobe br_netfilter
echo 1 > /proc/sys/net/bridge/bridge-nf-call-iptables
echo 1 > /proc/sys/net/ipv4/ip_forward
2 Likes

How to maintain this configuration after a system reboot?

Just wanted to confirm that this worked on a lab I was doing with acloudguru. Same exact error as OP’s post, but just running the ‘modprobe br_netfilter’ command worked. Thank you!