[Network errors] - Microk8s

I have been trying to find a solution all day but could not correct the issue so I try asking the community :slightly_smiling_face:

I have installed via snap a microk8s cluster with dns addon enabled on my ubuntu 20.04 laptop for testing purposes (v1.21)
For some reasons when I try using any curl command from within a pod deployed on this cluster I get an error as follows:

curl https://www.google.com
curl: (60) SSL: no alternative certificate subject name matches target host name ‘www.google.com

I tried launching a pod with the ubuntu :latest image for debugging purposes and tried running apt-get update -y as the root user.
I then get the following error:

oot@test:/# apt-get update -y
Err:1 http://archive.ubuntu.com/ubuntu focal InRelease
403 Forbidden [IP: 80]
Err:2 http://security.ubuntu.com/ubuntu focal-security InRelease
Reading package lists… Done

N: See apt-secure(8) manpage for repository creation and user configuration details.*
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.*

It seems like I have Network errors from any pod within the microk8s cluster. I could not figure how to correct this issue.

Does anyone have an idea?
I would be pleased to provide any further details required.

Thank you very much and have a nice day.


Just found out that it was my ISP who was rewriting my requests with a suffix domain…
I reconfigured my dhcp/settings to ignore the search domain and it works like a charm.
The issue is not related to microk8s