Web server does not respond in spite of the fact all K8S indicators are OK

Hi, I have K8S with docker desktop, I apply a deployment as well as a service and forward port 80 to port 8080. Issuing the following commands show that everything is OK
1 - get pods
stable-deployment-7cc45c64fb-5vgp6 1/1 Running 0 31m
stable-deployment-7cc45c64fb-6x8m4 1/1 Running 0 31m
stable-deployment-7cc45c64fb-cdwk4 1/1 Running 0 31m
stable-deployment-7cc45c64fb-vtmt6 1/1 Running 0 31m

2 - get services

3 - describe service
Name: stable-service
Namespace: default
Labels: app=aspnetcore
Selector: app=aspnetcore
Type: LoadBalancer
IP Family Policy: SingleStack
IP Families: IPv4
LoadBalancer Ingress: localhost
Port: 80/TCP
TargetPort: 8080/TCP
NodePort: 31951/TCP
Endpoints:,, + 1 more…
Session Affinity: None
External Traffic Policy: Cluster

When I browse the application at http:localhost:8080 it does not respond. The question is : How can I troubleshoot/debug why the web server is not responding? Knowing that when I run the same image used in the deployment using docker run, website responds correctly on port 8080
Thanks for your help

Since it was a Docker Desktop issue I share where we discussed it. I guess it would have worked the same way in Rancher Desktop, but I tried only NodePort.