Alternative install methods for MicroK8s

MicroK8s is spectacularly easy to install and use on Ubuntu or any Linux which supports snaps - see the Getting started tutorial. For other platforms or less common scenarios, see the relevant notes and links below.

Operating systems



Other environments

Other architectures

Currently MicroK8s is actively tested and developed on amd64 and arm64. If you run into difficulties running on other architectures (e.g. PPC/S390), please follow the procedure to file a bug

Raspberry Pi 4 installation works, yet performance is very poor, with a load factor ranging from 7 to 14 when adding clustered nodes.

The green disk light is on constantly, and an iostat run shows very I/O bound.

It would be great to hear from forum how to diagnose further.

As a temporary measure, will attempt to boot an SSD from USB 3.0.

What is the process causing this load? Do top and iotop show anything?

With regards to offline installation, do you think it will be good to add some reminder that snap core needs to be downloaded too?

Yes, this came up the other day and is on my list - just wanted to test there isn’t anything else which needs to be done e.g. on RHEL

1 Like

Do you think we should add instructions on how to load the calico images to containerd? Or the cluster will always be in NotReady state.


I was excited to install MicroK8s and try on Windows 10. I already have wsl2 and docker installed. Installing MicroK8s installed 2 components.

  1. Microk8s binary
  2. Multipass

First I tried with Hyper-v vm creation for multipass, it did not work. Even it said its created, microk8s always asked to install and failed.
Then when I tried with Virtualbox there also I did not find the vm and still when multipass was showing running. Has anyone else experienced such issues.

I’ve tried MicroK8s + multipass on windows 10. I just need to increase the memory to 4GB though.
What error are you getting?

The Multipass section is not showing in the sidebar TOC, possibly because the html has no id. (For macOS, for example, it is : id=“heading–macos”).

thanks, I’ll check into that

On Chrome, you need to enable chrome://flags/#allow-insecure-localhost because the latest Chrome will not give you the choice to continue even with invalid certificate

1 Like

For Windows, are there command line arguments for different install locations and other options? I don’t want to install to C:, which has limited space.

I found that on macOS microk8s enable dashboard dns registry istio doesn’t fully work, and running microk8s status confirms that registry and istio are not actually available (anymore?). So maybe those steps need updating?

Registry should be available but not istio.
I don’t think there is an arm version of istio. Definitely not included in the addons.

Uhm… I might be missing something, but why does the Windows Installer allow me to choose where to Install Multipass, but installs Microk8s on C:\Programblaba automatically? My C Drive is kind of overloaded (old PC), so I usually install Progs to the other drives… but to install/configure Microk8s during the installation, I need to create a VM, which is trying to use the next to no space I have on Drive C? Where can I change this?

@Bogoy_Hafner I’m not sure this is a problem with the docs, but more a shortcoming of the installer. I think it would be more appropriate to file a bug - Sign in to GitHub · GitHub