No listener on IPv4 25000

I’m setting up a 4 node cluster, 2 on x86 and 2 on arm, I want to see how kubernetes handles different architecture.

I initially setup microk8s on Ubuntu running in a VM on EXSI Fling and then added another Ubuntu VM node and 2 Rocky Linux nodes on x86 VMs.

Everything was going splendidly, following a tutorial I loaded a deployment pod and everything was working as expected, until something went wonky with the storage on the Ubuntu VM and the VM went read only. This was the master node and I had to reboot it to get it working properly again. After the reboot the pod was in CrashKernel state and was complaining about lack of DNS for the cluster. I read a number posts about this and was unable to fix this so I decided to start over and put the master on one of the x86 nodes instead of the Ubuntu nodes which are prone to going read only.

My first attempt was to reset microk8s and that failed so I did a snap remove and re-install. Now I am unable to get nodes to join the cluster. The join command seems to work as it chugs away and returns the prompt but never actually appears in the cluster. When I look at the listeners I can see port 25000 is bound to IPv6, but I don’t see a listener on IPv4. Since the join command I’m using is telling the joining node to connect to the IPv4 IP and port 25000 so it seems like it has to have the listener.

Am I barking up the wrong tree or is there a solution I’m not seeing?


I don’t know how many people viewed this, but I figured it out. My VMs are allowing IPV6 and the ports are binding to IPV6 rather than IPV4. My solution was to disable IPV6 and when I did everything bound to IPV4 and my troubles vanished. I think I need to find a better solution though, the ports should bind to both IPV4 and IPV6, but at least for now I’m working.