Not able to access remote Kubernetes cluster on same network

I am not able to access remote Kubernetes cluster behind VPN but on same network.

kubectl get po

I0930 21:38:58.483735 19996 versioner.go:56] Remote kubernetes server unreachable
Unable to connect to the server: dial tcp i/o timeout

I am trying to access Kubernetes cluster, which is deployed on VM. I can do ssh on VM and my kubctl command worked.

But if I am trying to connect from local by copying config file from cluster, its throw above error.

I tried to ping or wget the URL of cluster its reachable but not reaching if its https://host:6443. look like that port is unavailable to access from outside of that VM.

Any suggestion on how can I access this cluster from my machine?

As I mentioned URL is accessible but not with port 6443. my .kube config file look like this:

apiVersion: v1
kind: Config
preferences: {}


  • cluster:
    server: https://host:6443
    certificate-authority: /common/onprem-ca.crt
    name: vmcluster


  • user:
    username: admin