How can I connect my macOS to docker network minikube?

I run the minikube on my macos, and minikube container use the minikube network, check below:

$ docker network ls
906776761e62   bridge     bridge    local
89afa32d0810   host       host      local
b7cc12043647   minikube   bridge    local
4f7dca22f5b6   none       null      local
$ docker network inspect b7cc12043647
        "Name": "minikube",
        "Id": "b7cc120436478e8be737a60df8fd0147e46ad09ccfbea41e564aaebff0f5ee27",
        "Created": "2021-09-28T09:57:59.40193434Z",
        "Scope": "local",
        "Driver": "bridge",
        "EnableIPv6": false,
        "IPAM": {
            "Driver": "default",
            "Options": {},
            "Config": [
                    "Subnet": "",
                    "Gateway": ""
        "Internal": false,
        "Attachable": false,
        "Ingress": false,
        "ConfigFrom": {
            "Network": ""
        "ConfigOnly": false,
        "Containers": {
            "a35d5e4b87e1bc2a747a8e1902c8bd9363d9ec1f1baf2424671d1a3a497f18ff": {
                "Name": "minikube",
                "EndpointID": "97d5f2ccc7a306f56200a0a6811f90db8e6cb0f8269762041797b2e9c25a1d63",
                "MacAddress": "02:42:c0:a8:31:02",
                "IPv4Address": "",
                "IPv6Address": ""
        "Options": {
            "--icc": "",
            "--ip-masq": "",
            "": "1500"
        "Labels": {
            "": "true"

and I also know docker on macos is running in Docker Desktop(linux VM), but now how can I use macos bridge connect to the linux VM?

Docker doesn’t provide you a way to connect to the hyperkit virtual machine; It’s custom built to only run docker. You generally should not have any reason to connect directly to it, but if you do, you can use this workaround from Justin Cormack:

Thanks for your response. the reason is I want to access the dashboard GUI. so I need to access it.

You should be able to do that via minikube - they have docs on how to access apps that have been deployed:

I tried before ask this question. minikube tunnel will get stuck there. on my macos.