Deploying homeassist to microk8s failing

Hi, I have a microk8s cluster working well. I deploy helloworld to it and ti works fine. I am trying to deploy homeassistant now. I have followed the blog Running HomeAssistant on Kubernetes Microk8s – Matt's Blog I am deploying to a single node which I specify in the yaml file that was posted in the blog. It uses a PV and I created the PV directory and gave permissions. The PV works fine. Files created in the pod on the PV are in the directory on the node… microk8s.kubectl logs says everything has stared. In the PV I have:

root@uk8s02:/data/homeassist# ls -la
total 604
drwxrwxr-x 6 billd microk8s   4096 Jul 15 01:21 .
drwxr-xr-x 3 root  root       4096 Jul 15 01:14 ..
-rw-r--r-- 1 root  root          8 Jul 15 01:21 .HA_VERSION
drwxr-xr-x 2 root  root       4096 Jul 15 01:21 .cloud
drwxr-xr-x 2 root  root       4096 Jul 15 01:24 .storage
drwxr-xr-x 4 root  root       4096 Jul 15 01:21 blueprints
-rwxr-xr-x 1 root  root          0 Jul 15 01:21 configuration.yaml
-rw-r--r-- 1 root  root          0 Jul 15 01:21 home-assistant.log
-rw-r--r-- 1 root  root          0 Jul 15 01:21 home-assistant.log.1
-rw-r--r-- 1 root  root          0 Jul 15 01:21 home-assistant.log.fault
-rw-r--r-- 1 root  root       4096 Jul 15 01:21 home-assistant_v2.db
-rw-r--r-- 1 root  root      32768 Jul 15 01:30 home-assistant_v2.db-shm
-rw-r--r-- 1 root  root     552112 Jul 15 01:30 home-assistant_v2.db-wal
drwxr-xr-x 2 root  root       4096 Jul 15 01:21 tts

now the strange thing is the first time I tried to run this up, the config file was empty and the home-assistant.log file had contest that said it found an error in the config.yaml, and that it was falling back to safe mode. The error was that I had put long and lat into the config file that is converted to base64 and passed in as a secret. This all seemed good as I was getting feedback. I just put the default of lat 0 and long 0 back in the config file ran it again and now I get this. nothing in the home assist log file to help me out and the pod says everything is hunky dory. I put the error back in the config file, run it again, I get the same thing every time now no matter what. I delete the secret every time I run a deployment, but I never get anything useful in log files of the app - I am pretty sure it restarts as there is a home-assistant.log.log.1 - which is also empty. Not sure that this is even the place to ask, but I just don’t know what to try next - other than what my friend says, which is to try K3s and frankly after trying everything I can think of here I guess that is what is next unless I can find something else to try and look at to determine what is going wrong.

Any ideas?